summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCorey Hinshaw2020-10-06 16:55:42 -0400
committerCorey Hinshaw2020-10-06 16:55:42 -0400
commit790e4ed7bba0445bf7b5350819564a890c2ed620 (patch)
tree9a9bf92f293e511ce622bfd84e8b90db08947339 /PKGBUILD
parentcd90c52740f6fd8cd9e02cbfba217b4ea7c65c81 (diff)
downloadaur-luks-tpm.tar.gz
Update to v1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fde2258705a..db1298e46899 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
-# Maintainer: Corey Hinshaw <coreyhinshaw@gmail.com>
+# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
+# Contributor: zer0def <zer0def@github>
pkgname=luks-tpm
-pkgver=0.2.2
+pkgver=1.0.0
pkgrel=1
pkgdesc="Utility to manage LUKS keyfiles sealed by the TPM"
arch=('any')
-url="https://github.com/electrickite/luks-tpm"
+url="https://github.com/electrickite/${pkgname}"
license=('GPL')
-depends=('tpm-tools' 'trousers' 'cryptsetup' 'coreutils' 'util-linux')
-source=('luks-tpm')
+depends=('tpm-tools' 'trousers' 'cryptsetup' 'bash' 'coreutils' 'gawk' 'grep' 'util-linux')
+install="${pkgname}.install"
+backup=('etc/default/luks-tpm')
-sha256sums=('45e4009da6ff8810cb38f4178a23023c0111563d2a500292459c58d6dd5e058c')
+source=("https://github.com/electrickite/${pkgname}/archive/${pkgver}.tar.gz"
+ "${pkgname}.hook")
+sha256sums=('ce4b48bfdcd4ecc5df672bf7264fb5abb3aef4b271eec2a24657be396332e86a'
+ '3b268c5e1d874d3b80698e3cfb245cccdfb6412cc6982a112812d7e3717b3b9d')
package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
install -Dm755 luks-tpm "${pkgdir}/usr/bin/luks-tpm"
+ install -Dm644 default "${pkgdir}/etc/default/luks-tpm"
+ install -Dm644 "${srcdir}/luks-tpm.hook" "${pkgdir}/usr/share/libalpm/hooks/luks-tpm.hook"
}