summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCorey Hinshaw2017-02-27 22:59:23 -0500
committerCorey Hinshaw2017-02-27 22:59:23 -0500
commit13e93ce1baef3a12a6cea6451d68c15796d09c2e (patch)
treebb2f6e51ca069dba3ed05a9f07d9a27d2678a8d8 /PKGBUILD
downloadaur-13e93ce1baef3a12a6cea6451d68c15796d09c2e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5086f28928c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Corey Hinshaw <coreyhinshaw@gmail.com>
+
+pkgname=luks-tpm
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Utility to manage LUKS keyfiles sealed by the TPM"
+arch=('any')
+url="https://github.com/electrickite/luks-tpm"
+license=('GPL')
+depends=('tpm-tools' 'trousers' 'cryptsetup' 'coreutils' 'util-linux')
+source=('luks-tpm')
+
+sha256sums=('97c7b2a7f45674e96ec25bd69f48bda7749c59bbf6744608d561f84410634198')
+
+package() {
+ install -Dm755 luks-tpm "${pkgdir}/usr/bin/luks-tpm"
+}