summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Maslowski2017-12-06 23:26:39 +0100
committerDaniel Maslowski2017-12-06 23:35:47 +0100
commit36e7d16b8249f686086239305550d48b4a89d45c (patch)
tree8b7eee7b9f5cce5ef2442daa2740445e3829a790 /PKGBUILD
parent86d0a31c2a96bb8febaf27578a38c81aca1905a3 (diff)
downloadaur-36e7d16b8249f686086239305550d48b4a89d45c.tar.gz
v1.4.0-p1 based on PKGBUILDs by pavbaranov and FredBezeies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 26 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76e9c7db4c8d..4966903e10d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,44 @@
-# Maintainer: Chad "crossroads1112" Sharp <crossroads1112@riseup.net>
+# Maintainer: Daniel Maslowski <info@orangecms.org>
+# Contributor: FredBezeies
+# Contributor: pavbaranov
+# Contributor: marcin82
+# Based on original PKGBUILD created by:
+# Contributor: Chad "crossroads1112" Sharp <crossroads1112@riseup.net>
pkgname=lumina-desktop
-pkgver=1.4.0
+_pkgver=1.4.0-p1
+pkgver=1.4.0p1
pkgrel=1
-pkgfullname="${pkgname%-*}-${pkgver}"
+pkgfullname="${pkgname%-*}-${_pkgver}"
pkgdesc="A Lightweight QT5 Desktop for FreeBSD"
arch=('x86_64' 'i686')
url="https://github.com/trueos/lumina"
license=('BSD')
-depends=('qt5-base' 'qt5-svg' 'qt5-multimedia' 'qt5-x11extras' 'fluxbox' 'oxygen' 'oxygen-icons' 'xscreensaver' 'desktop-file-utils')
-optdepends=('xorg-xbacklight: required for changing screen brightness' 'alsa-utils: required for adjusting audio volume' 'acpi: required for monitoring battery life' 'numlockx: required for changign state of numlock at login' 'pavucontrol: required for detatched audio mixer' 'fluxmod-styles: A good set of Fluxbox themes to improve the appearence of window decorations' 'network-manager-applet: Manage network connections from panel' 'xterm: Terminal emulator')
+depends=('poppler-qt5' 'qt5-x11extras' 'qt5-multimedia')
+optdepends=('xorg-xbacklight: required for changing screen brightness'
+ 'alsa-utils: required for adjusting audio volume'
+ 'acpi: required for monitoring battery life'
+ 'numlockx: required for changign state of numlock at login'
+ 'pavucontrol: required for detatched audio mixer'
+ 'fluxmod-styles: A good set of Fluxbox themes to improve the appearence of window decorations'
+ 'network-manager-applet: Manage network connections from panel'
+ 'xterm: Terminal emulator'
+ 'fluxbox: window manager for Lumina DE')
makedepends=('qt5-base' 'qt5-tools')
conflicts=("lumina-de-git" "lumina-desktop-git" "insight-fm")
provides=("${pkgname%-*}" "insight-fm")
install="${pkgname%-*}.install"
-source=("https://github.com/trueos/lumina/archive/v${pkgver}.tar.gz")
-sha512sums=('7243fc366a851832d9431df8ae8cac0f70a7bc92bed1282e78e5775c6593d799a07e2cac7042d770c8d6c4758bb142523027d67227a2282b47ed945b0e617cb0')
+source=("https://github.com/trueos/lumina/archive/v${_pkgver}.tar.gz")
+sha512sums=('340079832f4f6c9c9c70f11d7743b7c7db6772897f6411a966bf2bd77124bab1fbac8f5751164fb8a08a12c4443f515aaee76b117b4f959263eeaa98dbcbe41e')
-
-build(){
- cd "$srcdir/${pkgfullname}"
- find $srcdir/${pkgfullname} -name *.desktop -exec sed -i 's/usr\/local/usr/' {} \;
- qmake-qt5 QMAKE_CFLAGS_ISYSTEM= PREFIX="/usr" QT5LIBDIR=/usr/lib/qt
+build() {
+ cd "${srcdir}/${pkgfullname}"
+ find "${srcdir}/${pkgfullname}" -name *.desktop -exec sed -i 's/usr\/local/usr/' {} \;
+ qmake QMAKE_CFLAGS_ISYSTEM= PREFIX="/usr" LIBPREFIX=/usr/lib QT5LIBDIR=/usr/lib/qt CONFIG+=WITH_I18N L_MANDIR=/usr/share/man L_ETCDIR="/etc"
make
}
package() {
- cd "$srcdir/${pkgfullname}"
+ cd "${srcdir}/${pkgfullname}"
make INSTALL_ROOT="${pkgdir}" install
- mv "${pkgdir}"/usr/etc "${pkgdir}"/etc
- mv "${pkgdir}"/usr/man "${pkgdir}"/usr/share/man
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}