summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEwout van Mansom2023-04-24 13:33:05 +0200
committerEwout van Mansom2023-04-24 13:33:05 +0200
commit5f9bef273300e0d3a02d1e2e92357ed15b3f47c1 (patch)
treebfcb4c2d1ffa5dbdec1fe40413270bc66dc4cd8e /PKGBUILD
parentabc3eced67d4b200f3c3ecf3ad70f094c24910d7 (diff)
downloadaur-5f9bef273300e0d3a02d1e2e92357ed15b3f47c1.tar.gz
use dynamic generated fossil tarball
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 199883169a9b..2dcca754dbf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Ewout van Mansom <ewout@vanmansom.name>
pkgname=lumosql
-pkgver=r339.be5579f
+pkgver=20230111
_sqlite_ver=3.37.2
_lmdb_ver=0.9.29
-pkgrel=4
+_tag=be5579f383
+pkgrel=1
pkgdesc='Adds privacy, security and performance options to SQLite.'
arch=('x86_64' 'aarch64')
url="https://lumosql.org/src/lumosql"
@@ -14,26 +15,19 @@ makedepends=('fossil' 'not-forking' 'tcl' 'tclx' 'readline' 'gzip' 'tar' 'perl'
provides=("lmdb=${_lmdb_ver}")
conflicts=('lmdb')
options=('!emptydirs')
-source=("${pkgname}::fossil+${url}#commit=be5579f383"
+source=("${url}/tarball/${_tag}/lumosql-src-trunk.tar.gz"
'sqlite-lemon-system-template.patch::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/sqlite/trunk/sqlite-lemon-system-template.patch'
'lumo-build-opts.patch'
'lmdb.pc'
'lumosql.pc')
-sha256sums=(SKIP
+sha256sums=('4aecb7bd2f67d20f4ad4d15203c92400bd52985f80051f2baa98480c4d3ddf7c'
'55746d93b0df4b349c4aa4f09535746dac3530f9fd6de241c9f38e2c92e8ee97'
'40e151879951d62d819dcc463cddbb10a26eddfdbdf7f27136315bac1b3fee10'
'6eed8c6fde6f5e2523099462779656f7cb92b3fc7384023d96508a6e73a730da'
'0b413acb44cf29ad939c831130b655fa6898241617fe29f799c76fb281daec50')
-pkgver() {
- cd "$pkgname"
- _hash=$(fossil info | sed -n 's/checkout: *\([0-9a-z]*\).*/\1/p' | cut -c 1-7)
- _revision=$(fossil info | sed -n 's/check-ins: *\(.*\)/\1/p')
- printf "r%s.%s" "$_revision" "$_hash"
-}
-
prepare() {
- cd "$pkgname"
+ cd "${pkgname}-src-trunk"
patch --forward --strip=1 --input="${srcdir}/lumo-build-opts.patch"
}
@@ -50,13 +44,13 @@ build() {
-DSQLITE_MAX_EXPR_DEPTH=10000 \
-DSQLITE_ENABLE_MATH_FUNCTIONS"
- cd "$pkgname"
+ cd "${pkgname}-src-trunk"
make build BENCHMARK_RUNS=0 USE_BDB=no USE_SQLITE=no KEEP_SOURCES=1 TARGETS="${_sqlite_ver}+lmdb-${_lmdb_ver}"
}
package() {
- cd "${pkgname}"
+ cd "${pkgname}-src-trunk"
install -Dm644 LICENCES/MIT.txt "${pkgdir}/usr/share/licenses/${pkgname}/MIT.txt"