summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMadotsuki2016-05-17 01:24:36 -0500
committerMadotsuki2016-05-17 01:24:36 -0500
commit8240996a79a0f3ecf80c336531a05e19a9d8c4ad (patch)
tree1f24ee9f572e621fc2d58df712a37a14b8c57b17 /PKGBUILD
downloadaur-8240996a79a0f3ecf80c336531a05e19a9d8c4ad.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bb200b76e45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Madotsuki <madotsuki@national.shitposting.agency>
+
+pkgname=lunarg-vulkan-sdk
+pkgver=1.0.3.1
+pkgrel=1
+pkgdesc="Vulkan loader for amdgpu-pro (It sucks, but you have to download it yourself and put it in the same directory as your PKGBUILD, see url), make sure you don't have dpkg installed"
+url='https://vulkan.lunarg.com'
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('amdgpu-pro')
+conflicts=('dpkg')
+
+build() {
+ sed -i -e '1,501d' ../vulkansdk-linux-x86_64-1.0.3.1.run
+ tar -C "${srcdir}" -xf ../vulkansdk-linux-x86_64-1.0.3.1.run
+}
+
+package() {
+ cd 1.0.3.1/install
+ rm -Rf vulkan-loader_1.0.3.1_amd64 vulkan-sdk-headers_1.0.3.1_amd64 vulkan-sdk-runtime_1.0.3.1_amd64
+ mkdir vulkan-loader_1.0.3.1_amd64 vulkan-sdk-headers_1.0.3.1_amd64 vulkan-sdk-runtime_1.0.3.1_amd64
+ cd vulkan-loader_1.0.3.1_amd64
+ ar x ../vulkan-loader_1.0.3.1_amd64.deb
+ tar -C "${pkgdir}" -xf data.tar.xz
+
+ cd ../vulkan-sdk-headers_1.0.3.1_amd64
+ ar x ../vulkan-sdk-headers_1.0.3.1_amd64.deb
+ tar -C "${pkgdir}" -xf data.tar.xz
+
+ cd ../vulkan-sdk-runtime_1.0.3.1_amd64
+ ar x ../vulkan-sdk-runtime_1.0.3.1_amd64.deb
+ tar -C "${pkgdir}" -xf data.tar.xz
+}