summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMajorana Oedipus2024-04-22 02:46:37 +0800
committerMajorana Oedipus2024-04-22 02:46:37 +0800
commit3ed993197906efab98e4773f5160b2080b3174df (patch)
tree1bd4c01893ae92e693378358fa2e136bc8314277 /PKGBUILD
parent5a098b559bf99e05f49e87c11e34e40c07c81d7f (diff)
downloadaur-3ed993197906efab98e4773f5160b2080b3174df.tar.gz
lush 1.2.1-3
Add a patch to fix error when linking against new binutils due to API change
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a0620c77cf5..16a575aaf5be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
-# Maintainer: Maximilian Stein <theoddbird@posteo.org>
+# Maintainer: Majorana Oedipus <majoranaoedipus@posteo.org>
+# Contributor: Maximilian Stein <theoddbird@posteo.org>
# Contributor: Thomas S Hatch <thatch45@gmail.com>
# Contributor: Hannes Rist <cowider@gmail.com>
# Contributor: ackalker <a.c.kalker@gmail.com>
pkgname=lush
pkgver=1.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="An object-oriented programming language designed for researchers, experimenters, and engineers interested in large-scale numerical and graphic applications."
-arch=('x86_64' 'i686')
+changelog="lush.changelog"
+arch=('x86_64')
url="http://lush.sourceforge.net"
license=('GPL')
+depends=('binutils')
optdepends=('gsl' 'lapack' 'sdl' 'opencv' 'alsa-lib' 'libxft')
options=('!libtool')
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
sha256sums=('1423085ef7c4ed83374333ba7a552e7f5f35add8db0c2478c8b00c96931ad8c9')
+prepare() {
+ patch -p1 -i $srcdir/../$pkgname-$pkgver.patch
+}
+
build() {
- cd "$srcdir/$pkgname"
- ./configure LIBS=-lz X_EXTRA_LIBS=-lfontconfig --prefix=/usr --with-x
+ cd "$srcdir/$pkgname"
+ ./configure LIBS=-lz X_EXTRA_LIBS=-lfontconfig --prefix=/usr --with-x
+ make DESTDIR="$pkgdir"/ world
}
package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir"/ install
-} \ No newline at end of file
+}