summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2016-03-24 21:51:45 +1100
committerMatthew Gamble2016-03-24 21:51:45 +1100
commit4e25499f0394dd4b6c2e6ec26bea20fce2f1649e (patch)
tree9459534b39830acccc387992ccc7ed7f5161df80 /PKGBUILD
downloadaur-lustache.tar.gz
Initial commit of v1.3.1 of lustache templating library
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1895ad4440f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+_lua_version=5.3
+
+pkgname=lustache
+pkgver=1.3.1
+_gittag="1.3.1-0"
+pkgrel=1
+pkgdesc="Mustache templates for lua"
+arch=("any")
+url="http://olivinelabs.com/lustache/"
+license=("custom:MIT")
+depends=("lua")
+source=("https://github.com/Olivine-Labs/lustache/archive/v${_gittag}.tar.gz")
+sha256sums=('540bd5e1f6d32aa44d5be946d1772910fb73b62fa909ca5a026c115ece4170f0')
+
+package() {
+ cd "lustache-${_gittag}"
+ install -Dm644 "src/lustache.lua" "${pkgdir}/usr/share/lua/${_lua_version}/lustache.lua"
+ _files=("context" "renderer" "scanner")
+ for _file in ${_files[@]}; do
+ install -Dm644 "src/lustache/${_file}.lua" "${pkgdir}/usr/share/lua/${_lua_version}/lustache/${_file}.lua"
+ done
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/lustache/LICENSE"
+}
+