summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-10-10 10:06:33 -0600
committerMark Wagie2021-10-10 10:06:33 -0600
commit0339933d14dd99ca3c4da60e4f6ec1ba90518c3e (patch)
treea2db318426e8506b4705864a402cb6f300eaf1c3 /PKGBUILD
parente04089dd896839d7561cf8f10e567fa21b4c6182 (diff)
downloadaur-0339933d14dd99ca3c4da60e4f6ec1ba90518c3e.tar.gz
add missing dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21adddf3dbad..f58333fc7cb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.8.3.r133.gd0d5b5fc
+pkgver=0.5.9.beta2.r11.gd56dff08
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -16,8 +16,7 @@ depends=('python-gobject' 'python-yaml' 'python-evdev' 'python-dbus' 'gtk3'
'python-pillow' 'python-requests' 'gnome-desktop' 'webkit2gtk'
'mesa-demos' 'python-dbus' 'python-distro' 'python-magic' 'python-lxml')
makedepends=('git' 'meson')
-#checkdepends=('xorg-server-xvfb' 'python-nose-cover3' 'wine' 'xterm'
-# 'gnome-desktop' 'pciutils' 'xorg-xrandr')
+#checkdepends=('xorg-server-xvfb' 'python-nose-cover3' 'wine' 'xterm')
optdepends=(
'wine: easiest way to get all the libraries missing from the Lutris runtime'
'vulkan-icd-loader: Vulkan support'
@@ -29,28 +28,29 @@ optdepends=(
'gamemode: Allows games to request a temporary set of optimisations'
"mangohud: Display the games' FPS + other information"
"lib32-mangohud: Display the games' FPS + other information"
- 'innoextract: Extract Inno Setup installers')
+ 'innoextract: Extract Inno Setup installers'
+ 'xorg-xgamma: Restore gamma on game exit')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/lutris/lutris.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson "${pkgname%-git}" build
- meson compile -C build
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
}
#check() {
-# cd "$srcdir/${pkgname%-git}"
-# xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml \
-# --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
+# cd "$srcdir/${pkgname%-git}"
+# xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml \
+# --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
#}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}