summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-04-11 16:53:01 -0600
committerMark Wagie2022-04-11 16:53:01 -0600
commit27d256e2bb0e91513dc21442d2ad2e6a8278988f (patch)
treef463ce7df1e7b7abbcc8c79c9583015d19e23a09 /PKGBUILD
parent9a46cf78c2332a5a704833d3eef243c5b3373d8f (diff)
downloadaur-27d256e2bb0e91513dc21442d2ad2e6a8278988f.tar.gz
use Meson test, test suite comments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1915e6ab61dd..ceb84f6dcf00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.10.beta2.r50.gac6ca06a
+pkgver=0.5.10.r26.g293ed419
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -16,7 +16,8 @@ depends=('dbus-python' 'cabextract' 'curl' 'glib2' 'gtk3' 'mesa-utils'
'python-pillow' 'python-requests' 'python-yaml' 'unzip'
'webkit2gtk' 'xorg-xrandr')
makedepends=('git' 'meson')
-checkdepends=('appstream-glib')
+checkdepends=('appstream-glib' 'pciutils' 'python-nose2' 'python-poetry'
+ 'xorg-server-xvfb' 'xterm')
optdepends=(
'gamemode: Allows games to request a temporary set of optimisations'
'gamescope: Draw the game window isolated from your desktop'
@@ -52,7 +53,14 @@ build() {
}
check() {
- appstream-util validate-relax --nonet build/net.lutris.Lutris.metainfo.xml
+ meson test -C build --print-errorlogs
+
+ cd "$srcdir/${pkgname%-git}"
+
+ # Run test suite
+ # Will produce errors if ~/.local/share/lutris, ~/.config/lutris
+ # and ~/.cache/lutris are not avialable / writable
+ xvfb-run --auto-servernum poetry run nose2
}
package() {