summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-10-16 20:06:08 -0600
committerMark Wagie2021-10-16 20:06:08 -0600
commit73919c4f4835cb2213ae19c89d47cd57f6f03fce (patch)
treea5e6a831e7b9e91b7bb5db0f812a70ca7abadda8 /PKGBUILD
parent0339933d14dd99ca3c4da60e4f6ec1ba90518c3e (diff)
downloadaur-73919c4f4835cb2213ae19c89d47cd57f6f03fce.tar.gz
add functional test
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f58333fc7cb8..b4654e341c88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.9.beta2.r11.gd56dff08
+pkgver=0.5.9.1.r0.gf4dee7ea
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -16,7 +16,7 @@ depends=('python-gobject' 'python-yaml' 'python-evdev' 'python-dbus' 'gtk3'
'python-pillow' 'python-requests' 'gnome-desktop' 'webkit2gtk'
'mesa-demos' 'python-dbus' 'python-distro' 'python-magic' 'python-lxml')
makedepends=('git' 'meson')
-#checkdepends=('xorg-server-xvfb' 'python-nose-cover3' 'wine' 'xterm')
+checkdepends=('appstream-glib')
optdepends=(
'wine: easiest way to get all the libraries missing from the Lutris runtime'
'vulkan-icd-loader: Vulkan support'
@@ -45,11 +45,9 @@ build() {
meson compile -C build
}
-#check() {
-# cd "$srcdir/${pkgname%-git}"
-# xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml \
-# --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
-#}
+check() {
+ appstream-util validate-relax --nonet build/net.lutris.Lutris.metainfo.xml
+}
package() {
meson install -C build --destdir "$pkgdir"