summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-08-01 13:05:49 -0600
committerMark Wagie2022-08-01 13:05:49 -0600
commita6979a9a182c823135b879e383d47f1e46cd0dc3 (patch)
tree7b8f320221c97b4bf5f32235548cf4218683df4a /PKGBUILD
parent4dfb70ec131b4e8e038df6c718c60cbe4904bea7 (diff)
downloadaur-a6979a9a182c823135b879e383d47f1e46cd0dc3.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a697cc096649..d5b9d4907975 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.10.1.r73.gf6e7d86b
+pkgver=0.5.10.1.r143.g069b098a
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -40,14 +40,24 @@ optdepends=(
'xorg-xgamma: Restore gamma on game exit')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/lutris/lutris.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/lutris/lutris.git'
+ 'https://github.com/lutris/lutris/pull/4395.patch')
+sha256sums=('SKIP'
+ '718a3beb54ea15bcadda40dbd463afd3e5e05f91bb417f2e73f88c111aca93e4')
pkgver() {
cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Correct syntax of fi.po
+ # https://github.com/lutris/lutris/issues/4394
+ patch -Np1 -i ../4395.patch
+}
+
build() {
arch-meson "${pkgname%-git}" build
meson compile -C build