summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-01-22 19:39:33 -0700
committerMark Wagie2021-01-22 19:39:33 -0700
commitb7940d46adfc0000fea762bd61f2abf3f7e81832 (patch)
tree5a3ad8c156706233cea0319f892d851f350f1980 /PKGBUILD
parent60caf9a373dcff84b8c431826d209fee25ec17b0 (diff)
downloadaur-b7940d46adfc0000fea762bd61f2abf3f7e81832.tar.gz
I mean it
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5552a12143a1..604ef59f4d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,30 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.8.2.r13.g5d5736b5
+pkgver=0.5.8.2.r12.g1b321f40
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
url='https://lutris.net/'
license=('GPL3')
depends=('python-gobject' 'python-yaml' 'python-evdev' 'python-dbus' 'gtk3'
- 'glib2' 'psmisc' 'cabextract' 'unzip' 'p7zip' 'curl' 'xorg-xrandr'
- 'python-pillow' 'python-requests' 'gnome-desktop' 'webkit2gtk'
+ 'glib2' 'psmisc' 'cabextract' 'unzip' 'p7zip' 'curl'
+ 'python-pillow' 'python-requests' 'webkit2gtk'
'mesa-demos' 'python-dbus' 'python-distro' 'python-magic-ahupp'
'python-lxml')
makedepends=('git' 'meson')
#checkdepends=('xorg-server-xvfb' 'python-nose-cover3' 'wine' 'xterm')
optdepends=(
- 'wine: Run windows games'
+ 'wine: easiest way to get all the libraries missing from the Lutris runtime'
'vulkan-icd-loader: Vulkan support'
'lib32-vulkan-icd-loader: Vulkan support'
'vkd3d: Vulkan 3D support'
'lib32-vkd3d: Vulkan 3D support'
'gvfs: GVFS backend'
- 'python-evdev: Detecting connected joypads'
+ 'xorg-xrandr: fetch screen resolutions on Xorg'
+ 'gnome-desktop: fetch screen resolutions on Wayland'
+ 'lib32-glibc: for 32bit games support'
+ 'python-evdev: for controller detection'
'python-pypresence: Discord RPC and Rich Presence'
'gamemode: Allows games to request a temporary set of optimisations'
"mangohud: Display the games' FPS + other information")
@@ -51,7 +54,6 @@ check() {
# cd "$srcdir/${pkgname%-git}"
# xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml \
# --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
-
}
package() {