summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Fuentes2020-10-11 17:20:24 -0400
committerVictor Fuentes2020-10-11 17:20:24 -0400
commitbd5c86b9b2a2fee35f88124576dae754f9661d98 (patch)
tree326382d4fbdb7bcfbc4bcd319779074c97e4bf4e /PKGBUILD
parent904b9ea23e54157f08dcbcd05624a28640c1b824 (diff)
downloadaur-bd5c86b9b2a2fee35f88124576dae754f9661d98.tar.gz
Add temporary test patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6fa1e0c4035..31002a033541 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=lutris-git
_pkgname=lutris
-pkgver=0.5.7.1.r232.g3edfd15b
+pkgver=0.5.7.1.r274.g88e4ffa6
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -29,8 +29,10 @@ optdepends=(
'python-pypresence: Discord RPC and Rich Presence')
provides=('lutris')
conflicts=('lutris')
-source=('git+https://github.com/lutris/lutris.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/lutris/lutris.git'
+ 'test-fix.patch')
+sha256sums=('SKIP'
+ '2e627ec7ddcfcc4c5180cb837163966705288c18cc75447872df6c669c9c7516')
pkgver() {
cd ${_pkgname}
@@ -46,7 +48,7 @@ build() {
check() {
cd ${_pkgname}
-
+ patch --strip=1 --input="${srcdir}/test-fix.patch"
xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
}