summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Fuentes2019-01-28 17:24:28 -0500
committerVictor Fuentes2019-01-28 17:24:28 -0500
commitc597c01b53a4d241ac34e9d4998b574de94a9d4e (patch)
tree873518ea951dd8b3c9c8d22b8ad8474bb3281c20 /PKGBUILD
parent1ec4baec0f1bc15a0f65dea9cfd0e851b24d5bb9 (diff)
downloadaur-c597c01b53a4d241ac34e9d4998b574de94a9d4e.tar.gz
Update and fix issues
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc5be268047b..ddc7a747e2d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
-# Maintainer: Michael DeGuzis <mdeguzis@gmail.com>
+# Maintainer: Victor Fuentes <hyruleterminatriforce@gmail.com>
+# Contributor: Filipe Laíns (FFY00) <lains@archlinux.org>
+# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.4.20.r5.54ad3b92
+_pkgname=lutris
+pkgver=0.5.0rc1.r0.g2b4a46b9
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
url='https://lutris.net/'
license=('GPL3')
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'polkit' 'xorg-xrandr'
- 'python-dbus' 'python-gobject' 'python-yaml' 'python-evdev'
- 'lib32-sqlite')
+depends=('python-gobject' 'python-yaml' 'python-evdev' 'gtk3' 'glib2' 'psmisc' 'cabextract' 'unrar' 'unzip' 'p7zip' 'curl' 'xorg-xrandr' 'gnome-desktop' 'python-requests' 'python-pillow')
makedepends=('git' 'python-setuptools')
+checkdepends=('xorg-server-xvfb' 'xterm' 'python-nose-cover3' 'wine' 'webkit2gtk')
optdepends=(
+ 'wine: Run windows games'
+ 'wine-staging: Run windows games - Staging patches'
'python-evdev: Detecting connected joypads.'
'python-pyinotify: Enhanced Steam integration.'
)
@@ -23,15 +27,19 @@ source=('git+https://github.com/lutris/lutris.git')
sha256sums=('SKIP')
pkgver() {
- cd lutris
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/v//; s/\([^-]*-g\)/r\1/;s/-/./g'
- git describe --tags | sed 's/v//; s/-/.r/; s/-g/./'
+}
+
+check() {
+ cd ${_pkgname}
+
+ xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
}
package() {
- cd lutris
+ cd ${_pkgname}
python setup.py install --root="${pkgdir}" --optimize='1'
}
-
-# vim: ts=2 sw=2 et: