summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Venries2016-10-26 22:58:36 +0200
committerThomas Venries2016-10-26 22:58:36 +0200
commit7041267f15420a755eb241dff7e7798df3580706 (patch)
tree5e1e096577284e458355f403d235a04fc4ba00ee /PKGBUILD
downloadaur-7041267f15420a755eb241dff7e7798df3580706.tar.gz
Initial Release v0.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d28fc6b6f5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Thomas "Ventto" Venriès <thomas.venries@gmail.com>
+
+pkgname=lux
+pkgver=0.7
+pkgrel=1
+pkgdesc='Bash script to easily control brightness on backlight controllers.'
+arch=('any')
+url="https://github.com/Ventto/${pkgname}.git"
+license=('GPL3')
+depends=('bash')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+makedepends=('help2man')
+source=("https://github.com/Ventto/lux/archive/v${pkgver}.tar.gz")
+sha256sums=('95155afc4a9cafe3132484df46295df8c9ef5473355aeaefd4192f7118ea05f8')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ help2man -h -h -v -v src/${pkgname}.sh | gzip - > ${pkgname}.1.gz
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 ${pkgname}.1.gz ${pkgdir}/usr/share/man/man1/${pkgname}.1.gz
+ install -Dm644 rules.d/99-${pkgname}.rules ${pkgdir}/etc/udev/rules.d/99-${pkgname}.rules
+ install -Dm755 src/${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}
+}