summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-10-04 14:37:18 +0200
committerbartus2018-10-04 14:37:18 +0200
commit1b60a81275fd992a0dc527a7de7ec2fe2f1207fe (patch)
treed54019c0595e1dfa5e6aa8622631c3fc5a8fa308 /PKGBUILD
parent5dfb13f1f794e127b4f770317baa67fd13f19f94 (diff)
downloadaur-1b60a81275fd992a0dc527a7de7ec2fe2f1207fe.tar.gz
pack alpha4 ver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ab3747a4c8a..6a7857785e2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=luxcorerender
pkgver=2.1
-pkgrel=1
+_alpha=4
+pkgrel=2
pkgdesc="LuxCoreRender is a physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
@@ -13,16 +14,16 @@ makedepends=(git doxygen cmake python-pyside-tools opencl-headers)
conflicts=(luxrays-hg)
provides=(luxrays)
options=('!buildflags')
-source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${pkgver}alpha1.tar.gz"
+source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${pkgver}alpha${_alpha}.tar.gz"
"python.patch"
"glfw.patch"
)
-md5sums=('43ec2a57c44681c2ebc308a563d15e60'
- 'a1b1594fbb809597759d0573702c06b2'
+md5sums=('7255c3027aab84ef7bed084af1ba850b'
+ '21b963e5f66d2c8c6a50bebcf9f0fe07'
'624f2be4cb431f6a4cfcc968d6263ac2')
prepare() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha1
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}
msg "python.patch"
patch -Np1 < ../python.patch
msg "glfw.patch"
@@ -30,14 +31,14 @@ prepare() {
}
build() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha1
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}
mkdir -p build && cd build
- cmake ..
+ cmake -DPYTHON_V=3 ..
make
}
package() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha1/build
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}/build
install -d -m755 ${pkgdir}/usr/{bin,include,lib}
install -m755 bin/* ${pkgdir}/usr/bin