summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-11-07 15:33:02 +0100
committerbartus2018-11-07 15:33:02 +0100
commit65635c8ff9313d739d5f0b9c7546c4be3916f6f7 (patch)
treeb959dfd9d5ca8e32b3f29ae2bcf8a528ca785e87 /PKGBUILD
parent9f770bbc44493fda2bb347dadda5433ae3c6dae4 (diff)
downloadaur-65635c8ff9313d739d5f0b9c7546c4be3916f6f7.tar.gz
fix ambiguous `PyContext` call
revert python35 > python
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffe30df74f06..381261cd9f4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=luxrender-hg
pkgver=4918+.f56582df55f4+
-pkgrel=5
+pkgrel=6
pkgdesc="Rendering system for physically correct, unbiased image synthesis"
arch=('x86_64')
url="http://www.luxrender.net/"
@@ -12,9 +12,9 @@ depends=('boost-libs' 'freeimage' 'openexr' 'openimageio' 'libpng' 'opencl-icd-l
'embree-bvh_build-git')
optdepends=('luxblend25: Blender exporter' \
'qt4: Qt GUI' \
- 'python35: pylux Python interface' \
+ 'python: pylux Python interface' \
'opencl-driver: OpenCL support')
-makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays-hg" 'python35' 'opencl-headers'
+makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays-hg" 'python' 'opencl-headers'
'eos_portable_archive' 'mercurial')
provides=('luxrender')
conflicts=('luxrender')
@@ -51,6 +51,10 @@ prepare() {
# fix unambiguous 'distance' function in boost/gcc8-stl
patch -Np1 -i ${srcdir}/gcc-8.patch
+
+ # fix unambiguous 'PyContext' both in python3.7 and lux::
+ sed -i 's/\&PyContext/\&lux::PyContext/g' python/pycontext.h
+ sed -i 's/class_<PyContext/class_<lux::PyContext/' python/pycontext.h
}
build() {
@@ -58,7 +62,7 @@ build() {
mkdir -p build
cd build
- _pyver=$(python3.5 -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
+ _pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \