summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 22:02:07 +0200
committerJerome Leclanche2015-06-09 22:02:07 +0200
commit8d5fd98d142e21e0355e292dc91efb2507870930 (patch)
tree5dfb72002e1b481a36773aa91bdb104431e25018 /PKGBUILD
downloadaur-8d5fd98d142e21e0355e292dc91efb2507870930.tar.gz
Initial import from old AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c318b4ce156c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=lxqt-qtplugin
+pkgname=$_pkgname-git
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="LXQt platform integration for Qt"
+arch=("i686" "x86_64")
+url="http://lxqt.org"
+license=("GPL2")
+depends=("liblxqt-git")
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxde/$_pkgname.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}