summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaimar Bühmann2022-12-17 01:07:36 +0100
committerRaimar Bühmann2022-12-17 01:07:36 +0100
commit1897aeb0fb774a7006745c112fca887b17a52318 (patch)
tree220be0421ab38fbe2243e1aaa15f4d77edc82a2d /PKGBUILD
parent0c45bf1ab6246b40df84940a743b572a7780bff6 (diff)
downloadaur-1897aeb0fb774a7006745c112fca887b17a52318.tar.gz
Update to 0.1.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 671500b976af..299fac589b8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Raimar Buehmann (raimar)
pkgname=lxtask-git
-pkgver=0.1.9.r411.20190912
+pkgver=0.1.10.r442.20211031
pkgrel=1
pkgdesc="Lightweight X11 task manager and system monitor for LXDE Desktop"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ conflicts=('lxtask')
replaces=('lxtask')
url="https://lxde.org/"
source=(
- $pkgname::git+https://github.com/OpenHelios/lxtask.git
+ $pkgname::git+https://github.com/OpenHelios/lxtask-mirror.git
# https://downloads.sourceforge.net/lxde/lxtask-0.1.8.tar.xz
# $pkgname::git+https://git.lxde.org/git/lxde/lxtask.git
# $pkgname::git+git://git.lxde.org/git/lxde/lxtask.git
@@ -22,9 +22,7 @@ source=(
sha256sums=(
'SKIP'
)
-
_gitroot=$pkgname
-
pkgver() {
# remove ".r*.*" from package version
_pkgverTriple=$(echo $pkgver | sed "s/\.r.*//g")
@@ -34,16 +32,14 @@ pkgver() {
# get time of last git commit
_commitTime=$(git show -s --format="%ci" | grep -o "....-..-.." | sed "s/-//g")
# add ".r*.*" from package version
- echo "$_pkgverTriple.r411.$_commitTime"
+ echo "$_pkgverTriple.r$_commitCount.$_commitTime"
}
-
build() {
cd $_gitroot
- autoreconf
+ autoreconf --install --force
./configure --prefix=/usr --sysconfdir=/etc
make
}
-
package() {
cd $_gitroot
make DESTDIR="$pkgdir" install