summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJure Varlec2018-08-13 23:08:20 +0200
committerJure Varlec2018-08-13 23:08:20 +0200
commitbe60f99183b6097aebb2688dd647c18933a51968 (patch)
tree598ec24bcad8342ed419bd929c883182ee4a3ff3 /PKGBUILD
parent975d3493e806c89d77416ac13166633d34505810 (diff)
downloadaur-lycklig-git.tar.gz
New location on github, pyqt5, drop wand dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 317060eb169b..f67c46801866 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Jure Varlec <jure.varlec@ad-vega.si>
_pkgname=lycklig
pkgname=lycklig-git
-pkgver=20150207
+pkgver=20180813
pkgrel=1
pkgdesc="Image processing for lucky imaging."
arch=( i686 x86_64 )
-url="https://gitorious.org/adv/${_pkgname}"
+url="https://github.com/AD-Vega/${_pkgname}.git"
license=('GPL3')
-depends=( opencv python3-wand python-pyqt4 python-scipy )
+depends=( opencv python-pyqt5 python-scipy )
makedepends=( git cmake boost tclap )
checkdepends=()
optdepends=()
@@ -22,7 +22,7 @@ source=()
noextract=()
md5sums=() #generate with 'makepkg -g'
-_gitroot="git://gitorious.org/adv/${_pkgname}.git"
+_gitroot="${url}"
_gitname="master"
build() {
@@ -33,7 +33,7 @@ build() {
cd $_gitname && git pull --rebase origin
msg "The local files are updated."
else
- git clone $_gitroot $_gitname
+ git clone --depth=1 $_gitroot $_gitname
cd $_gitname
git checkout $_gitname
cd -