summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbart2019-08-30 10:43:49 +0200
committerbart2019-08-30 10:43:49 +0200
commit0069dae1ea26a1b65ac55f7ed00ed8e5f9bbf78b (patch)
treefc408a49cc36eb4ba3f41f06877c2f6f812315f8 /PKGBUILD
downloadaur-0069dae1ea26a1b65ac55f7ed00ed8e5f9bbf78b.tar.gz
initial release
Signed-off-by: bart <b.willems@wimionline.be>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e9f94479c9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=lyriek
+pkgver=0.1.0
+pkgrel=1
+arch=('x86_64' 'i686')
+url="https://gitlab.com/bartwillems/lyriek"
+license=('GPL3')
+depends=('dbus' 'gtk3')
+makedepends=('rust' 'cargo' 'git' 'desktop-file-utils')
+conflicts=('lyriek-git')
+source=("https://gitlab.com/bartwillems/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('d9d359554fcf8a1dd21f7556a953b4949616c69c536f36d106f1193358e9525b')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ pkgdesc="A multi-threaded GTK application to fetch lyrics of currently playing songs"
+ provides=('lyriek')
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ desktop-file-install -m 644 --dir "$pkgdir/usr/share/applications/" "extras/lyriek.desktop"
+ install -D -m755 "target/release/lyriek" "$pkgdir/usr/bin/lyriek"
+ install -D -m644 "assets/logo.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/lyriek.svg"
+}