summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-06-19 11:38:30 +0800
committerChocobo12017-06-19 11:56:56 +0800
commit22f4ff5f8eb252c83f49bdb11b7c2217d9e26c8b (patch)
tree085babb8cf55a32220e0730009f460b539706ce8 /PKGBUILD
downloadaur-22f4ff5f8eb252c83f49bdb11b7c2217d9e26c8b.tar.gz
newpkg: lz4-git 1.7.4.2.r221.g89b9f02-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08bb1ced1ad6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=lz4-git
+pkgver=1.7.4.2.r221.g89b9f02
+pkgrel=1
+pkgdesc="Extremely Fast Compression algorithm"
+arch=('i686' 'x86_64')
+url="https://lz4.github.io/lz4/"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+provides=('lz4')
+conflicts=('lz4')
+source=("git+https://github.com/lz4/lz4.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "lz4"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "lz4"
+
+ make
+}
+
+check() {
+ cd "lz4"
+
+ #make test
+}
+
+package() {
+ cd "lz4"
+
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}