summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-11-03 02:03:59 +0000
committerDaniel Bermond2020-11-03 02:03:59 +0000
commit229fb26b76eac348561fe0e6761bb52d463498d5 (patch)
tree47fd0ab860c5cc39dd448f2a20d37e76ed184ebb /PKGBUILD
parent5c0ac432c12f796d56b9b5551bd8fd23b7514ca5 (diff)
downloadaur-229fb26b76eac348561fe0e6761bb52d463498d5.tar.gz
Update to version 20201101
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a53f76bedaf2..8345d4b6ca40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20201029
+pkgver=20201101
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
@@ -10,20 +10,20 @@ license=('GPL3')
depends=('freetype2' 'hidapi' 'libgl' 'libpng' 'libsamplerate' 'minizip'
'qt5-base' 'qt5-websockets' 'sdl2' 'sdl2_net' 'zlib' 'hicolor-icon-theme')
optdepends=('p7zip: for 7z/zip support')
-makedepends=('git' 'cmake' 'nasm' 'zip' 'icoutils')
+makedepends=('git' 'cmake' 'nasm' 'python' 'zip' 'icoutils')
provides=('mupen64plus-gui' 'mupen64plus-video-gliden64')
conflicts=('mupen64plus-gui' 'mupen64plus-video-gliden64' 'mupen64plus')
-_commit=277f5752e1589c7060cfe30eddb34ca21eb84dce
+_commit=aa3d849a2705bc62b9cb08e236a4819ae81c54b8
source=("git+https://github.com/loganmc10/m64p.git#commit=${_commit}"
'010-m64p-remove-build-jobs-limitation.patch'
'020-m64p-enable-optimizations.patch'
- '030-m64p-fix-default-config-paths.patch'
+ '030-m64p-fix-paths.patch'
'040-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
- 'b1b73a03aa63d855c930b01695a842528a17b15cb1f72aab04c539cd10874db9'
- '516620afe7deafa114dbada63330f32adafbc92cac0bfc46db10fcd31805da6e'
- 'feb20cb2a812a13858cce2674965c6db6b61b2712f7069bea9b38266bed3f25b'
+ '4c483f9bf3230171c433d7f8310881babbd02416ce16079e85fd0ef254442d57'
+ 'a35c7370d4545356cfcc9b10ad84250685510744911fde8910ecd224da046711'
+ 'fe5d5e200f7c2fa5146b56346bd57d95c440e36569608ab0738700b0f57935cc'
'0075fe9463f3c629066c5dd4f6407f11ff413b0f76fcd15ac61905f210c42e02'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
@@ -31,7 +31,7 @@ prepare() {
icotool -x m64p/mupen64plus-gui/mupen64plus.ico -o m64p/mupen64plus-gui
patch -d m64p -Np1 -i "${srcdir}/010-m64p-remove-build-jobs-limitation.patch"
patch -d m64p -Np1 -i "${srcdir}/020-m64p-enable-optimizations.patch"
- patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-default-config-paths.patch"
+ patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-paths.patch"
patch -d m64p -Np1 -i "${srcdir}/040-m64p-add-pie.patch"
}
@@ -62,8 +62,11 @@ package() {
_sover="$(find "${pkgdir}/usr/lib" -type f -name 'libmupen64plus.so.*.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"
- # other plugins
+ # other plugins and components
+ install -D -m644 m64p/mupen64plus/libdiscord_game_sdk.so -t "${pkgdir}/usr/lib"
install -D -m644 m64p/mupen64plus/mupen64plus-input-qt.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 m64p/mupen64plus/mupen64plus-rsp-parallel.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 m64p/mupen64plus/mupen64plus-video-angrylion-plus.so -t "${pkgdir}/usr/lib/mupen64plus"
install -D -m644 m64p/mupen64plus/mupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
install -D -m644 m64p/mupen64plus/GLideN64.custom.ini -t "${pkgdir}/usr/share/mupen64plus"
}