summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-10-18 20:17:39 +0000
committerDaniel Bermond2020-10-18 20:17:39 +0000
commit708717124cfef7fc1e6d1dc9a73496c817220df2 (patch)
tree20c384e4ccca52514bc81dfee5017ec934976cec /PKGBUILD
parentffbd33e58583fd1cbe11e3fb2970691897e06654 (diff)
downloadaur-708717124cfef7fc1e6d1dc9a73496c817220df2.tar.gz
Update to version 20201017
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70cc7146ba29..706eaf3ae42e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20201012
+pkgver=20201017
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
@@ -13,20 +13,23 @@ optdepends=('p7zip: for 7z/zip support')
makedepends=('git' 'cmake' 'nasm' 'icoutils')
provides=('mupen64plus-gui' 'mupen64plus-video-gliden64')
conflicts=('mupen64plus-gui' 'mupen64plus-video-gliden64' 'mupen64plus')
-_commit=41e17c6616660687e95833f66ac1b6b24f89abcc
+_commit=e6180a8e0766707df29d94b4ad59a039a48b0dd2
source=("git+https://github.com/loganmc10/m64p.git#commit=${_commit}"
'010-m64p-remove-build-jobs-limitation.patch'
'020-m64p-enable-optimizations.patch'
+ '030-m64p-fix-default-config-paths.patch'
'm64p.desktop')
sha256sums=('SKIP'
'28c95005fbfa3b30bcee412070c5fc13f74a2b6f52526a9ad733778de3aaec04'
'd3834a29ccf06be9ad1c0a3039efb4ed69d81f61e814d1578a6bd19474aa11c3'
+ 'ce455d2bf39dd958e76ca6342820293895bab7376988fdb27537408057c36176'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {
icotool -x m64p/mupen64plus-gui/mupen64plus.ico -o m64p/mupen64plus-gui
patch -d m64p -Np1 -i "${srcdir}/010-m64p-remove-build-jobs-limitation.patch"
patch -d m64p -Np1 -i "${srcdir}/020-m64p-enable-optimizations.patch"
+ patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-default-config-paths.patch"
}
build() {