summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-05-04 21:30:41 +0000
committerDaniel Bermond2020-05-04 21:30:41 +0000
commitfd2a90b9f1ec77aa49bc380c8c414ce7af6d3ad0 (patch)
tree3e9662b45e2b9636767c548bf52ec6af91376a7a /PKGBUILD
parent81fb5a2ddd94ba03a49d95a513cee26a5cf8d08a (diff)
downloadaur-fd2a90b9f1ec77aa49bc380c8c414ce7af6d3ad0.tar.gz
Fix icon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea6b7ae881da..0e10bf7171f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=m64p
pkgver=20200504
-pkgrel=1
+pkgrel=2
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
url='https://m64p.github.io/'
license=('GPL3')
depends=('freetype2' 'glu' 'hidapi' 'libgl' 'libpng' 'libsamplerate'
- 'minizip' 'p7zip' 'qt5-base' 'sdl2' 'zlib')
-makedepends=('git' 'cmake' 'nasm')
+ 'minizip' 'p7zip' 'qt5-base' 'sdl2' 'zlib' 'hicolor-icon-theme')
+makedepends=('git' 'cmake' 'nasm' 'icoutils')
provides=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
conflicts=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
source=("git+https://github.com/loganmc10/m64p.git#tag=$(LC_ALL='C' date -d "$pkgver" +%b%-d%Y | tr '[:upper:]' '[:lower:]')"
@@ -33,7 +33,7 @@ sha256sums=('SKIP'
'SKIP'
'6871b495ace8a9005d93ce3e9103a15111a67793812dd5158072c981c4c3a5a8'
'a999739626fc3e9d0102b65014c436bf4e9039587ccac174334672f3925f4495'
- 'b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df')
+ '8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {
git -C m64p submodule init
@@ -58,7 +58,19 @@ package() {
# mupen64plus-gui
install -D -m755 m64p/mupen64plus/mupen64plus-gui -t "${pkgdir}/usr/bin"
install -D -m644 m64p.desktop -t "${pkgdir}/usr/share/applications"
- install -D -m644 mupen64plus-gui/mupen64plus.ico "${pkgdir}/usr/share/pixmaps/m64p.ico"
+ icotool -x mupen64plus-gui/mupen64plus.ico
+ local _count='1'
+ local _depth
+ local _file
+ local _res
+ while read -r -d '' _file
+ do
+ _depth="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*x//' )"
+ _res="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*_//;s/x.*$//')"
+ install -D -m644 "mupen64plus_${_count}_${_res}x${_res}x${_depth}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/mupen64plus.png"
+ _count="$((_count + 1))"
+ done < <(find -maxdepth 1 -type f -name 'mupen64plus_*_*x*x*.png' -print0 | sort -z)
# mupen64plus components
local _component