summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvsibille2022-03-03 19:30:32 -0500
committervsibille2022-03-03 19:32:13 -0500
commit0eae732902468ae483818ce6b8e0deff0882fd5c (patch)
treed9b6e3f579bb3590db65b2544707f7fdc92b0c0f /PKGBUILD
parentafbe166aedfb9f07604a7075a0fe6e3ce7476c84 (diff)
downloadaur-0eae732902468ae483818ce6b8e0deff0882fd5c.tar.gz
Set RPATH directly at build stage (!= install) for convenience
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fed09914c9b5..426d8d88ca32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dakeryas <mrdakeryas at gmail dot com>
pkgname=mac-optimised
pkgver=7.38
-pkgrel=1
+pkgrel=2
pkgdesc="Monkey's Audio library and command line APE converter with optimised build flags (from SDK)"
arch=('i686' 'x86_64')
url="https://monkeysaudio.com/developers.html"
@@ -16,20 +16,15 @@ _project_path() {
echo "$srcdir/Source/Projects/NonWindows"
}
-_mac_cmd_object() {
- echo "$(awk '/CMDOBJECTS\s+=/{print $NF}' $(_project_path)/Makefile)"
-}
-
build() {
cd $(_project_path)
export prefix=/usr
export CXXFLAGS="${CXXFLAGS} -O3 -march=native"
+ export LDFLAGS="${LDFLAGS} -Wl,-rpath,\\$\$ORIGIN/../lib"
make
}
package() {
cd $(_project_path)
- export LDFLAGS="${LDFLAGS} -Wl,-rpath,\\$\$ORIGIN/../lib"
- touch $(_mac_cmd_object)
make DESTDIR="$pkgdir/" install
}