summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2021-07-22 11:20:03 +0300
committerChristoph Gysin2021-07-22 11:20:03 +0300
commit93a059c5ec9bce2d0707b147f0222ead1b34885e (patch)
tree6d8bbc34b8f18ce103fff3da4641465321e122c8 /PKGBUILD
parentae8d3c385fbcac73cdfa1c2d898f8f7cbf807f61 (diff)
downloadaur-93a059c5ec9bce2d0707b147f0222ead1b34885e.tar.gz
Fix build against >=linux-5.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed84ba2b58d6..31af47609cbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=macbook12-spi-driver
pkgname=(${_pkgbase}-dkms)
pkgver=0+git.304
-pkgrel=1
+pkgrel=2
pkgdesc="Driver for the keyboard, touchpad and touchbar found in newer MacBook (Pro) models"
arch=('i686' 'x86_64')
url="https://github.com/roadrunner2/macbook12-spi-driver"
@@ -14,10 +14,12 @@ makedepends=('git')
optdepends=()
source=(git+https://github.com/roadrunner2/macbook12-spi-driver.git#branch=touchbar-driver-hid-driver
dkms.conf
- linux-5.9.patch::https://github.com/PatrickVerner/macbook12-spi-driver/commit/5328c33cf2fc40208811cd6e191890537db6aeb4.diff)
+ linux-5.9.patch::https://github.com/PatrickVerner/macbook12-spi-driver/commit/5328c33cf2fc40208811cd6e191890537db6aeb4.diff
+ linux-5.13.patch::https://github.com/PatrickVerner/macbook12-spi-driver/commit/cb139b1f725ef23063c787028bcb8287571cffae.diff)
sha256sums=('SKIP'
'e42243352d015a78e5d13260361d3052d0b84c4105bcb89191a319f2249cc47b'
- '79b1782aef96c03d399e3c76617ee80c9df26269e87b0a454f97830581a44539')
+ '79b1782aef96c03d399e3c76617ee80c9df26269e87b0a454f97830581a44539'
+ '78124048bb151f09486df4767ccb3f657a2c19415e642ad1486ee3f640d9fa79')
pkgver() {
cd $_pkgbase
@@ -27,6 +29,7 @@ pkgver() {
prepare() {
cd $_pkgbase
patch -Np1 -i ${srcdir}/linux-5.9.patch
+ patch -Np1 -i ${srcdir}/linux-5.13.patch
}
package() {