summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrtcdr2021-04-15 01:06:54 +0100
committergrtcdr2021-04-15 01:06:54 +0100
commit8c30b949c94e5a7489205cae04f206a0a607d3af (patch)
treec5f9e02251d9eaee4e43533c97237bdaf54276bd /PKGBUILD
parentc95182a93cc6a6e57a25937b4d5439fcf895cbe3 (diff)
downloadaur-8c30b949c94e5a7489205cae04f206a0a607d3af.tar.gz
New features, tweaks and bug fixes
- You might have noticed that PKGBUILD is now a little different, it utilizes checksums, to keep you safe, and the source has changed as well.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 627617944dc9..6fbf921fdbec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
# Maintainer: grtcdr <ba.tahaaziz@gmail.com>
pkgname=macchina
-pkgver=0.6.7
+pkgver=0.6.9
pkgrel=1
-pkgdesc="Basic system information fetcher, written in Rust"
+pkgdesc="A system information fetcher, with an emphasis on performance and minimalism."
arch=('x86_64')
-url="https://github.com/grtcdr/macchina"
+url="https://github.com/Macchina-CLI/macchina"
license=('MIT')
depends=('gcc-libs' 'glibc')
optdepends=('wmctrl: window manager support')
makedepends=('rust' 'cargo' 'git')
-source=("$pkgname::git+${url}.git")
-md5sums=('SKIP')
-prepare() {
- cd "$pkgname"
-}
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+
+sha256sums=('0923bdc46dc5491aa3693b69e3c0cb3d17be5201ae349c2bc8cde1814606a629')
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
cargo build --release
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
targetdir=${CARGO_TARGET_DIR:-target}
- install -Dm755 "$targetdir/release/macchina" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$targetdir/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}