summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortrya2015-06-08 23:35:39 +0200
committertrya2015-06-08 23:35:39 +0200
commitf029b32f9178a3d848a05279ee5d749268f82f8f (patch)
treec3bcc82c1c0e18c26c067290b93d388dcdc8cd42 /PKGBUILD
downloadaur-f029b32f9178a3d848a05279ee5d749268f82f8f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f9d39cece89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: trya <tryagainprod@gmail.com>
+
+pkgname=mach64drm
+pkgver=20150222
+pkgrel=1
+pkgdesc="Mach64 DRM module"
+arch=('i686' 'x86_64')
+url="http://dri.freedesktop.org/wiki/DRM"
+license=('GPL')
+depends=('linux')
+makedepends=('linux-headers')
+optdepends=('mach64-dri: Mesa DRI drivers for Mach64'
+ 'xf86-video-mach64: X.Org Mach64 video driver')
+source=(http://trya.alwaysdata.net/linux/mach64-$pkgver.tar.gz)
+md5sums=('b763647c584bb524db3d7418651dcd4e')
+install="mach64drm.install"
+
+build() {
+ cd "$srcdir/mach64-$pkgver"
+ make
+}
+
+package() {
+ install -Dm644 "$srcdir/mach64-$pkgver/mach64.ko" \
+ "$pkgdir/usr/lib/modules/`uname -r`/kernel/drivers/gpu/drm/mach64/mach64.ko"
+}