summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMF Akane2019-09-24 05:31:53 +0900
committerMF Akane2019-09-24 05:35:04 +0900
commitf9aab2b160178df52146fbb6f584ef621b5c4332 (patch)
treeac11d2eea9719d7d3648410e8b486f7ba7c553fb /PKGBUILD
parent889b8001ee86fbd102ecf4734a7f0127902cb730 (diff)
downloadaur-f9aab2b160178df52146fbb6f584ef621b5c4332.tar.gz
Fix build failure
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32a0df18a2ef..6e9ec49bcb29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: MF Akane <aur at sorairo dot pictures>
pkgname=mackerel-agent-plugins-git
pkgver=0.58.0
-pkgrel=1
+pkgrel=2
pkgdesc="Plugins for mackerel-agent"
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/mackerelio/mackerel-agent-plugins"
license=('Apache')
depends=()
-makedepends=('git' 'go' 'jq' 'perl')
+makedepends=('git' 'go' 'perl')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("$pkgname"::'git+https://github.com/mackerelio/mackerel-agent-plugins.git')
@@ -20,21 +20,12 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
-
- export GOPATH="$srcdir/go"
- mkdir -p "$GOPATH"
-
- make deps
- mkdir -p build
-
- for i in `cat "$srcdir/$pkgname/packaging/config.json" | /usr/bin/jq -r '.plugins[]'`; do
- cd "$srcdir/$pkgname/mackerel-plugin-$i"
- go build -ldflags "-s -w" -o "$srcdir/$pkgname/build/mackerel-plugin-$i"
- done
+ make build
}
package() {
- for i in `cat "$srcdir/$pkgname/packaging/config.json" | /usr/bin/jq -r '.plugins[]'`; do
- install -Dm755 "$srcdir/$pkgname/build/mackerel-plugin-$i" "$pkgdir/usr/bin/mackerel-plugin-$i"
+ for i in `cat "$srcdir/$pkgname/packaging/deb/debian/source/include-binaries"`; do
+ filename=$(basename $i)
+ install -Dm755 "`ls $srcdir/$pkgname/build/linux/*/$filename | head -n 1`" "$pkgdir/usr/bin/$filename"
done
}