summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBatuhan Baserdem2020-04-22 14:04:45 -0400
committerBatuhan Baserdem2020-04-22 14:04:45 -0400
commit5c422e9ea8e2c4a53325c37b4b0cd0e15dce29cd (patch)
tree4b1b0b89041de82b30c80f484f117cdd692d1f27 /PKGBUILD
parent1cbd5e437b3d007da3f433b1e1ff6e28b606f5bc (diff)
downloadaur-5c422e9ea8e2c4a53325c37b4b0cd0e15dce29cd.tar.gz
Fixed the directories in build script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b41734cd28cd..22157269f5f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,8 @@
# Maintainer: Batuhan Baserdem <lastname dot firstname at gmail>
+# AUR dependencies;
+# maestral (vcs or release, maintained by coxackie & me)
+# python-bugsnag (vcs, maintained by me)
+# python-markdown2
pkgname=maestral-qt
pkgver=1.0.0.dev4
pkgrel=1
@@ -16,23 +20,19 @@ depends=(
'python-markdown2'
'python-packaging'
'python-pyqt5>=5.9')
-# maestral: AUR dependency (git-version maintained by me)
-# python-bugsnag: AUR dependency (git-version maintained by me)
-# python-markdown2: AUR dependency
optdepends=('gnome-shell-extension-appindicator: Gnome integration')
+md5sums=('5416f536d33a2eaef8fd637bc1dbb0c5')
build() {
- cd "${srcdir}/${_name}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build
}
package() {
- # Change into the source git directory
- cd "${srcdir}/${_name}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
# Run python setup function
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
# Install the licence
- install -Dm644 "${srcdir}/${_name}/LICENSE.txt" \
- "${pkgdir}/usr/share/licenses/${_name}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-md5sums=('5416f536d33a2eaef8fd637bc1dbb0c5')