summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-02-24 17:58:51 -0600
committerLuis Martinez2022-02-24 17:58:51 -0600
commitc927d59745be4e26e6eec5c02aced1f7bf0b9a2d (patch)
tree84cef8610c8229a715e3970bae269088f59a29f7 /PKGBUILD
parent5a80a7de7fef31355b50598bafc9bf178b4bdc5a (diff)
downloadaur-c927d59745be4e26e6eec5c02aced1f7bf0b9a2d.tar.gz
use python-installer for packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 981026e98fd6..5e07909eff1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=maestral-qt
pkgver=1.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='Qt interface for Maestral'
arch=('any')
url="https://github.com/SamSchott/maestral-qt"
@@ -15,19 +15,19 @@ depends=(
'python-packaging'
'python-pyqt5')
optdepends=('gnome-shell-extension-appindicator: Gnome integration')
-makedepends=('python-build' 'python-install' 'python-wheel')
+makedepends=('python-build' 'python-installer' 'python-wheel')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('d8f85c1cc3e5449f494c81f490997d6b4c300c3829b7a4ee5c1841cdc718a3f5')
build() {
cd "$pkgname-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
package() {
export PYTHONHASHSEED=0
cd "$pkgname-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}