summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStorm Dragon2019-03-30 11:49:17 -0400
committerStorm Dragon2019-03-30 11:49:17 -0400
commitacd6b7cd97260734c8fc062d330c980ed87f746e (patch)
treec14eaf5e7385ea1ba5295ef815dbd217fc747bf0 /PKGBUILD
parent60bbf4bb6984668a9ac0ac92653844dab562bbd2 (diff)
downloadaur-acd6b7cd97260734c8fc062d330c980ed87f746e.tar.gz
Temp patch to fix dilation issues.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9731ba789eb..591eda24384b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname=magic-wormhole-git
_pkgname=${pkgname%-*}
-pkgver=0.10.2
-pkgrel=2
+pkgver=0.11.2.r82.995d3f5
+pkgrel=1
pkgdesc="Securely transfer data between computers"
arch=('any')
url="https://github.com/warner/${_pkgname}"
license=('MIT')
depends=('python' 'python-click' 'python-cffi' 'python-autobahn' 'python-tqdm' 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize' 'python-idna' 'python-service-identity' 'python-txtorcon' 'python-pyhamcrest')
makedepends=('python-setuptools')
-source=("git+${url}.git")
+source=("git+${url}.git" "magic-wormhole-git.patch")
conflicts=("wormhole" "wormhole-server")
provides=("wormhole" "wormhole-server")
-md5sums=('SKIP')
+sha512sums=('SKIP'
+ 'b93a25d041c6cded94eed8951d448bf84373516e49498289275e080cba487ea6905128b83c1f7ccb635f1f8045bcdefa0bce6ef9d493060c85b177d65011bbf2')
pkgver()
{
@@ -21,6 +22,10 @@ pkgver()
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
+prepare() {
+ patch < "magic-wormhole-git.patch" "$srcdir/$_pkgname/setup.py"
+}
+
build() {
cd "${srcdir}/${_pkgname}"
python setup.py build