summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2019-08-23 08:12:39 +0200
committerbartus2019-08-23 08:12:39 +0200
commit1eadd48a04948ed4cf0617787f00fc316e008768 (patch)
tree89c01854f359019ee15ee034075bd19741b034e5 /PKGBUILD
parent1e3ec19ca54c3f5213f8f7682f90fc20acff60ae (diff)
downloadaur-1eadd48a04948ed4cf0617787f00fc316e008768.tar.gz
Fix: CMAKE_INSTALL_PREFIX messing up default install path
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5815e2cddcf6..3877571593ad 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
#!/hint/bash
#shellcheck disable=SC2034
-# Maintainer: pingplug <pingplug@foxmail.com>
+# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+# Contributor: pingplug <pingplug@foxmail.com>
# Contributor: cornholio <vigo.the.unholy.carpathian@gmail.com>
##### Configuration Options
@@ -54,6 +55,12 @@ prepare() {
)
fi
fi
+
+ # Unset CMAKE_INSTALL_PREFIX preserve default install path
+ if [ -v CMAKE_INSTALL_PREFIX ] ; then
+ msg "You have CMAKE_INSTALL_PREFIX set to \"$CMAKE_INSTALL_PREFIX\". We have to clear it to preserve magma default install path"
+ unset CMAKE_INSTALL_PREFIX
+ fi
}
build() {