summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2019-08-29 11:59:13 +0200
committerbartus2019-08-29 12:06:25 +0200
commita42b552342c8df1573e3ecdd1650dab76e77d859 (patch)
treedf6d3019578b7b0da55f8c09eb964259481a2f8b /PKGBUILD
parent84a4dd6d6cad3f5d36245f1d32d9bc7724d5d16b (diff)
downloadaur-a42b552342c8df1573e3ecdd1650dab76e77d859.tar.gz
Refactor build()
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57f0b8041977..5c07ae484966 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,14 +57,13 @@ build() {
}
package() {
- cd "${srcdir}/magma-${pkgver}/build-shared"
- # do not build test
- sed -i "s/install: preinstall/install: magma_sparse/g" Makefile
- make DESTDIR="${pkgdir}" install
- cd "${srcdir}/magma-${pkgver}/build-static"
- # do not build test
- sed -i "s/install: preinstall/install: magma_sparse/g" Makefile
- make DESTDIR="${pkgdir}" install
+ for dir in ${srcdir}/magma-${pkgver}/build-*; do
+ pushd "$dir"
+ # do not build test
+ sed -i "s/install: preinstall/install: magma_sparse/g" Makefile
+ make DESTDIR="${pkgdir}" install
+ popd
+ done
mkdir -p ${pkgdir}/opt/magma/example
cp -ru ${srcdir}/magma-${pkgver}/example/* ${pkgdir}/opt/magma/example/