summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Andersson2015-09-07 15:29:56 +0200
committerMaxim Andersson2015-09-07 15:29:56 +0200
commitad115cb3ebd282180723030f28b2100fe0feb4c7 (patch)
treed22af9df052b93cea575a5b53afef74ea667c1af /PKGBUILD
parent843200d301097ce164b96c900848fb76a82f5252 (diff)
downloadaur-ad115cb3ebd282180723030f28b2100fe0feb4c7.tar.gz
Change dependency to gnupg 1.4
The GnuPG 1.4 AUR binary is named gpg1 (to not conflict with the GnuPG 2.1 pkg). So 'gpg' had to be changed to 'gpg1' in this pkg. Mailpile plan to change to GnuPG 2.1 in upcoming releases. https://github.com/mailpile/Mailpile/issues/1133
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9dcae06e96a0..bb3626bb2725 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=mailpile
pkgver=0.5.2
-pkgrel=2
+pkgrel=3
pkgdesc="A modern, fast web-mail client with user-friendly encryption and privacy features."
arch=('any')
url="http://www.mailpile.is"
license=('AGPL3')
-depends=('gnupg' 'python2-jinja>=2.6' 'python2-lxml>=2.3.2' 'python2-markupsafe' 'python2-pgpdump' 'python2-pillow' 'python2-pydns' 'spambayes>=1.1a6')
+depends=('gnupg1' 'python2-jinja>=2.6' 'python2-lxml>=2.3.2' 'python2-markupsafe' 'python2-pgpdump' 'python2-pillow' 'python2-pydns' 'spambayes>=1.1a6')
install=${pkgname}.install
source=("https://github.com/pagekite/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.service")
@@ -23,6 +23,10 @@ prepare() {
sed -i "s^('static/^('/usr/share/mailpile/static/^g" mailpile/config.py
sed -i '/os.path.dirname( # scripts/d' mp
sed -i 's^__file__))^"/usr/share/mailpile/mailpile")^g' mp
+
+ # Use gnupg 1.4
+ sed -i "s/gpg'/gpg1'/g" mailpile/crypto/gpgi.py
+ sed -i "s/gpg /gpg1 /g" mailpile/plugins/crypto_gnupg.py
}
build() {