summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoakim Nylén2017-10-06 12:30:53 +0200
committerJoakim Nylén2017-10-06 12:30:53 +0200
commit23a1d3772d10250d2d31be6a622d8cee207d7500 (patch)
tree7de677fa356d8113c91a41d945d9f11aa5271f8b /PKGBUILD
parent9076b3969c9df6632cd35b24ef153ef5b41ac68c (diff)
downloadaur-23a1d3772d10250d2d31be6a622d8cee207d7500.tar.gz
Final fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5154e596ccd8..94d862409622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mailspring
pkgver=1.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="A beautiful, fast and maintained fork of Nylas Mail by one of the original authors."
arch=('x86_64')
license=('GPL3')
@@ -22,7 +22,10 @@ package() {
tar -xvf data.tar.xz -C ${pkgdir} --exclude='./control'
# mailspring calls libsasl2.so.2 for some reason when arch have .3
- ln -s /usr/lib/libsasl2.so.3 /usr/lib/libsasl2.so.2
+ if [[ ! -f "/usr/lib/libsasl2.so.2" && -f /usr/lib/libsasl2.so.3 ]]
+ then
+ ln -s /usr/lib/libsasl2.so.3 /usr/lib/libsasl2.so.2
+ fi
chmod -R go-w "${pkgdir}"/usr
}