summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormurlakatamenka2019-09-01 13:53:00 +0300
committermurlakatamenka2019-09-01 13:53:00 +0300
commit05b536e3e72bbaf564f5900600ddbca5d6220f1a (patch)
tree0f9e9aed52ec976c28314edfff78c573fb3bef2f /PKGBUILD
downloadaur-maketorrent.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fe249566e9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sergey A. <murlakatamenka@disroot.org>
+
+pkgname=maketorrent
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="CLI .torrent file generator written in Rust"
+arch=('x86_64')
+url="https://github.com/fuchsi/maketorrent"
+license=('GPL3')
+depends=('rust')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+md5sums=('20c9babb7d0e32e7b168a71990446005')
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked
+}
+
+package() {
+ install -Dm 755 "$pkgname-$pkgver"/target/release/${pkgname} -t "${pkgdir}/usr/bin"
+}