summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Rizzitello2023-03-16 07:53:46 -0400
committerChris Rizzitello2023-03-16 07:53:46 -0400
commit0c592fbabcc91f7cfd6a300328a6d33048584d37 (patch)
tree2c7a1ff0398607c4abf042245ca5ae1b2e9a6d8f /PKGBUILD
parent0d81ba8ac3816e0bce064d412d4a8f16d60b1ae4 (diff)
downloadaur-makoureactor.tar.gz
v2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df39662c8dfc..ee55a6b75c7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
# Maintainer: Chris Rizzitello <sithlord48@gmail.com>
pkgname=makoureactor
conflicts=('makoureactor-git')
-pkgver=1.8.3
+pkgver=2.0.0
pkgrel=1
pkgdesc="Final Fantasy 7 Field Editor"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/myst6re/makoureactor"
license=('GPL3')
-depends=('qt5-base' 'freeglut' 'zlib') #Qt5)
+depends=('qt6-base' 'zlib' 'libff7tk') #Qt6)
#optdepends=('otf-ipafont: font for displaying japanese')
-source=("https://github.com/myst6re/makoureactor/archive/1.8.3.tar.gz")
-md5sums=(5748befdbad30c8de88634a88b302d30)
+source=("https://github.com/myst6re/makoureactor/archive/2.0.0.tar.gz")
+sha256sums=('167d58cb904d3285321ba05447e9b1bacf80b87085562aafa1406d9d523721d9')
build() {
- cd "makoureactor-1.8.3"
- qmake-qt5 Makou_Reactor.pro #Qt5 Build
- make
+ cmake -S"makoureactor-$pkgver" -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DBUNDLE_FF7TK_QM=OFF
+ cmake --build build
}
package(){
- cd "makoureactor-1.8.3"
- INSTALL_ROOT=$pkgdir make install
- install -D -m644 debian/menu "$pkgdir"/usr/share/menu/makoureactor
+ DESTDIR="$pkgdir" cmake --install build
}