summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMustafa Kuscu2017-11-22 21:22:48 +0300
committerMustafa Kuscu2017-11-22 21:22:48 +0300
commitb2fe262ea5d613f629e067313e74643d08486d7d (patch)
tree5a3e350cb05bd2c3b9b873d327e1a3c4eb45fb17 /PKGBUILD
downloadaur-b2fe262ea5d613f629e067313e74643d08486d7d.tar.gz
initial build, based on upstream 1.0.5 package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81c65cca1713
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mustafa Kuscu <mustafakuscu@gmail.com>
+pkgname=man-pages-tr
+pkgver=0.1
+pkgrel=1
+pkgdesc='A collection of Turkish translations of Linux manual pages'
+arch=('any')
+license=('GPL')
+url='http://sourceforge.net/projects/belgeler/'
+depends=('man-db')
+makedepends=('sed')
+source=(http://downloads.sourceforge.net/project/belgeler/man-pages-tr/man-pages-tr-1.0.5/man-pages-tr-1.0.5.tar.gz)
+md5sums=('8f322a60c80e31c34ef8979edaf68aae')
+
+prepare() {
+# remove the following from source, as they already exist in the file system
+rm man-pages-tr-1.0.5/source/man1/{chage,passwd}.1.xml
+rm man-pages-tr-1.0.5/source/man5/{passwd,shadow}.5.xml
+rm man-pages-tr-1.0.5/source/man8/{groupadd,groupdel,groupmod,useradd,userdel,usermod}.8.xml
+}
+
+package() {
+ cd $srcdir/man-pages-tr-1.0.5
+
+ make DESTDIR=$pkgdir utf8
+ make DESTDIR=$pkgdir deb-install
+}
+