summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2016-07-11 20:44:26 -0400
committergraysky2016-07-11 20:44:26 -0400
commit004fe1c21cf1575cc03b54396329ee124cf11b63 (patch)
tree77b4028b590cc012db06c8ad01c3d9b6b7661899 /PKGBUILD
downloadaur-004fe1c21cf1575cc03b54396329ee124cf11b63.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddb0926a6efc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: graysky <graysky AT archlinux DOT org>
+
+pkgname=mandb-ondemand
+pkgver=1.10
+pkgrel=1
+pkgdesc="Rebuild man-db cache/purge ondemand and speed up pacman operations."
+arch=('any')
+url="http://github.com/graysky2/mandb-ondemand"
+license=('MIT')
+depends=('systemd' 'man-db')
+conflicts=('man-db-systemd')
+replaces=('man-db-systemd')
+optdepends=('gzip')
+install=${pkgname}.install
+source=(https://github.com/graysky2/${pkgname}/archive/v1.10.tar.gz)
+sha256sums=('02cc1eb12a6dcd6d39ac11a5fe6fcc29928289c35a89d8ad419e061572e440a4')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir" install
+}