summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJordan Cannon2022-09-13 13:27:49 -0500
committerJordan Cannon2022-09-13 13:27:49 -0500
commit7fe86e8cb177ec0dad95e5cbeb3ad33384ba6d0f (patch)
tree5f5c52ad4dd251ca469237a7e27c7fbce23aaf61 /PKGBUILD
parent77c5911b2d681235147177665b8b8605936e23d9 (diff)
downloadaur-7fe86e8cb177ec0dad95e5cbeb3ad33384ba6d0f.tar.gz
Update to v0.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a7ae18241bc..f49b3125ee01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jordan Cannon <LiteracyFanatic@gmail.com>
pkgname=manga-sharp
-pkgver=0.2.0
-pkgrel=2
+pkgver=0.3.0
+pkgrel=1
pkgdesc='CLI manga downloader and reader with lightweight web interface'
arch=(x86_64)
url='https://github.com/LiteracyFanatic/manga-sharp'
@@ -13,14 +13,16 @@ source=("git+https://github.com/LiteracyFanatic/manga-sharp#tag=v$pkgver")
sha256sums=(SKIP)
prepare() {
- cd "$srcdir/$pkgname"
- npm install
- mkdir -p src/CLI/wwwroot/assets
- cp node_modules/bulma/css/bulma.min.css src/CLI/wwwroot/assets/
+ cd "$srcdir/$pkgname/src/Client"
+ yarn
}
build() {
+ cd "$srcdir/$pkgname/src/Client"
+ yarn build
cd "$srcdir/$pkgname"
+ mkdir -p src/CLI/wwwroot/
+ cp -R src/Client/dist/* src/CLI/wwwroot/
dotnet publish -c Release -r linux-x64 --no-self-contained -o dist src/CLI/
}