summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarvin Delgado2023-01-13 22:29:56 -0400
committerDarvin Delgado2023-01-13 22:29:56 -0400
commit0a46ee9c57763e62d64edc3ed12e867ce1ed426c (patch)
tree2a92234056357c397458159fb23eebfc8a7aa43f /PKGBUILD
parente898e620e55c03787a0f2f66f5305c3fc34bab96 (diff)
downloadaur-0a46ee9c57763e62d64edc3ed12e867ce1ed426c.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 20 insertions, 57 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ad1d043aa3e..eb4b553528cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,78 +1,41 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
-_pkgbase=mangohud
-pkgbase=$_pkgbase-git
-pkgname=('mangohud-git' 'lib32-mangohud-git' 'mangohud-common-git')
-pkgver=0.6.6.1.r181.g284ae0d
+_pkgname=mangohud
+pkgname=mangohud-git
+pkgver=0.6.8.r48.ga67ba60
pkgrel=1
+pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more."
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'dbus' 'meson' 'python-mako' 'glslang' 'libglvnd' 'lib32-libglvnd'
- 'vulkan-headers' 'vulkan-icd-loader' 'lib32-vulkan-icd-loader'
- 'libxnvctrl')
-source=("$_pkgbase::git+$url")
+makedepends=('dbus' 'gcc' 'git' 'glslang' 'libx11' 'libxnvctrl' 'meson' 'pkgconf' 'python-mako' 'vulkan-headers')
+depends=('glew' 'glfw-x11' 'hicolor-icon-theme')
+provides=('mangohud' 'mangohud-common' 'mangoapp')
+conflicts=('mangohud' 'mangohud-common' 'mangoapp')
+source=("${_pkgname%"-git"}::git+$url")
sha512sums=('SKIP')
pkgver() {
- cd "$_pkgbase"
+ cd "${_pkgname%"-git"}"
git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
-
build() {
- __meson_opts=(
+ local meson_options=(
--wrap-mode=forcefallback
- -Dappend_libdir_mangohud=false
-Duse_system_vulkan=enabled
+ -Dappend_libdir_mangohud=false
+ -Dmangohudctl=true
+ -Dmangoapp_layer=true
-Dtests=disabled
- "$_pkgbase"
+ "${_pkgname%"-git"}"
)
- arch-meson "${__meson_opts[@]}" build64
-
- ninja -C build64
-
- export \
- CC="gcc -m32" \
- CXX="g++ -m32" \
- PKG_CONFIG_PATH="/usr/lib32/pkgconfig" \
- LLVM_CONFIG="/usr/bin/llvm-config32"
-
- arch-meson "${__meson_opts[@]}" build32 --libdir lib32
- ninja -C build32
- unset CC CXX PKG_CONFIG_PATH LLVM_CONFIG
-}
-
-package_mangohud-git() {
- pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more'
- depends=('gcc-libs' 'dbus' 'mangohud-common-git')
- conflicts=('mangohud')
- provides=("mangohud=$pkgver")
- replaces=('vulkan-mesa-layer-mango')
- optdepends=('bash: mangohud helper script'
- 'libxnvctrl: support for older NVIDIA GPUs')
-
- meson install --destdir="$pkgdir" -C build64 --tags runtime
-}
+ arch-meson "${meson_options[@]}" build
-package_lib32-mangohud-git() {
- pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32-bit)'
- depends=('lib32-gcc-libs' 'lib32-dbus' 'mangohud-common-git')
- conflicts=('lib32-mangohud')
- provides=("lib32-mangohud=$pkgver")
- replaces=('lib32-vulkan-mesa-layer-mango')
- optdepends=('lib32-libxnvctrl: support for older NVIDIA GPUs')
-
- meson install --destdir="$pkgdir" -C build32 --tags runtime
- mv "$pkgdir/usr/share/vulkan/implicit_layer.d/MangoHud.json" "$pkgdir/usr/share/vulkan/implicit_layer.d/MangoHud.x86.json"
+ ninja -C build
}
-package_mangohud-common-git() {
- pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more'
- conflicts=('mangohud-common')
- provides=("mangohud-common=$pkgver")
-
- meson install --destdir="$pkgdir" -C build64 --tags man,doc,scripts
-
- install -Dm664 "$_pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$_pkgbase/LICENSE"
+package() {
+ meson install --destdir="$pkgdir" -C build
+ install -Dm664 "${_pkgname%"-git"}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}