summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarvin Delgado2023-01-18 18:45:11 -0400
committerDarvin Delgado2023-01-18 18:45:11 -0400
commit0acd0d4bd755965e2d3406db654fb4f97666990b (patch)
treebc8a0cfb31cea2a45116fead35406de176e8077f /PKGBUILD
parentcc2fcb3a616311ae9d580379783d0a37ffa28750 (diff)
downloadaur-0acd0d4bd755965e2d3406db654fb4f97666990b.tar.gz
file conflicts fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b74f19a26117..d82fa8006914 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,9 @@ optdepends=(
'libxnvctrl: NVIDIA GPU stats'
'lib32-mangohud-git: 32-bit support'
)
-provides=('mangohud')
-replaces=('mangohud-common-git' 'vulkan-mesa-layer-mango')
+provides=('mangohud' 'mangohud-common')
+conflicts=('mangohud' 'mangohud-common' 'mangohud-common-git')
+replaces=('mangohud-common-git')
source=("${_pkgname%"-git"}::git+$url")
sha512sums=('SKIP')
@@ -40,4 +41,5 @@ build() {
package() {
meson install --destdir="$pkgdir" -C build
install -Dm664 "${_pkgname%"-git"}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm "$pkgdir/usr/share/vulkan/implicit_layer.d/libMangoApp.json"
}