summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjackun2022-07-14 23:03:29 +0300
committerjackun2022-07-14 23:03:29 +0300
commit8d2e6e437ac1278a68071c804bd309acd339f562 (patch)
tree65cc710bbbed9c795fe1173f9d55d6aa2ccd8351 /PKGBUILD
parentbffa4c8d6f701d5d2c513ce7eafa0981aedcda54 (diff)
downloadaur-8d2e6e437ac1278a68071c804bd309acd339f562.tar.gz
Use meson's install_tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be438e23910d..7e58c7807165 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,8 +51,7 @@ package_mangohud-git() {
optdepends=('bash: mangohud helper script'
'libxnvctrl: support for older NVIDIA GPUs')
- DESTDIR="$pkgdir" ninja -C build64 install
- rm -r "$pkgdir/usr/bin" "$pkgdir/usr/share/doc" "$pkgdir/usr/share/man" "$pkgdir/usr/share/vulkan/implicit_layer.d/libMangoApp.json"
+ meson install --destdir="$pkgdir" -C build64 --tags runtime
}
package_lib32-mangohud-git() {
@@ -63,8 +62,7 @@ package_lib32-mangohud-git() {
replaces=('lib32-vulkan-mesa-layer-mango')
optdepends=('lib32-libxnvctrl: support for older NVIDIA GPUs')
- DESTDIR="$pkgdir" ninja -C build32 install
- rm -r "$pkgdir/usr/bin" "$pkgdir/usr/share/doc" "$pkgdir/usr/share/man" "$pkgdir/usr/share/vulkan/implicit_layer.d/libMangoApp.json"
+ meson install --destdir="$pkgdir" -C build32 --tags runtime
mv "$pkgdir/usr/share/vulkan/implicit_layer.d/MangoHud.json" "$pkgdir/usr/share/vulkan/implicit_layer.d/MangoHud.x86.json"
}
@@ -73,8 +71,7 @@ package_mangohud-common-git() {
conflicts=('mangohud-common')
provides=("mangohud-common=$pkgver")
- DESTDIR="$pkgdir" ninja -C build64 install
- rm -r "$pkgdir/usr/lib" "$pkgdir/usr/share/vulkan"
+ meson install --destdir="$pkgdir" -C build64 --tags man,doc,scripts
install -Dm664 "$_pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$_pkgbase/LICENSE"
}