summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarvin Delgado2020-03-15 12:02:38 -0400
committerDarvin Delgado2020-03-15 12:02:38 -0400
commitf7581699a97cb1d44488e71b20cc5753a34e598b (patch)
tree752e1391e1b4c8ef7cc71da30d51fc0faa25a797 /PKGBUILD
parent67a7bd801b13ca140298d230bf677906f4b4f170 (diff)
downloadaur-f7581699a97cb1d44488e71b20cc5753a34e598b.tar.gz
updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 30 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e29f80f48384..1e29c56970cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,71 +1,74 @@
-# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
_pkgbase=mangohud
pkgbase=$_pkgbase-git
-pkgname=('mangohud-git' 'lib32-mangohud-git')
-pkgver=0.1.0.r24.g1bc513f
+pkgname=('mangohud-git' 'lib32-mangohud-git' 'mangohud-common-git')
+pkgver=0.3.0.r25.g71b6027
pkgrel=1
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-depends=('gcc-libs' 'libx11')
-makedepends=('meson' 'python-mako' 'glslang' 'libglvnd' 'lib32-libglvnd')
-source=("$_pkgbase::git+$url.git"
- 'Vulkan-Docs::git+https://github.com/KhronosGroup/Vulkan-Docs.git'
- 'Vulkan-Loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git'
- 'ImGui::git+https://github.com/flightlessmango/ImGui.git'
- 'Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git')
+depends=('glslang' 'libglvnd' 'lib32-libglvnd' 'vulkan-headers')
+makedepends=('gcc' 'meson' 'python-mako' 'libx11' 'lib32-libx11' 'git')
+replaces=('vulkan-mesa-layer-mango' 'lib32-vulkan-mesa-layer-mango')
+source=("$_pkgbase::git+$url#branch=develop"
+ 'ImGui::git+https://github.com/flightlessmango/ImGui.git')
sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/${_pkgbase}"
+ cd "$_pkgbase"
git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
cd "$_pkgbase"
git submodule init
- git config submodule.'modules/Vulkan-Docs'.url "$srcdir/Vulkan-Docs"
- git config submodule.'modules/Vulkan-Loader'.url "$srcdir/Vulkan-Loader"
git config submodule.'modules/ImGui/src'.url "$srcdir/ImGui"
- git config submodule.'modules/Vulkan-Headers'.url "$srcdir/Vulkan-Headers"
git submodule update
}
build() {
- arch-meson "$_pkgbase" build64
+ arch-meson "$_pkgbase" build64 \
+ --libdir lib/mangohud/lib64 \
+ --prefix /usr \
+ -Dappend_libdir_mangohud=false \
+ -Dinclude_doc=false
+
ninja -C build64
export CC="gcc -m32"
export CXX="g++ -m32"
- export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig:/usr/lib/i386-linux-gnu/pkgconfig:/usr/lib/pkgconfig:${PKG_CONFIG_PATH_32}"
export LLVM_CONFIG="/usr/bin/llvm-config32"
- arch-meson "$_pkgbase" build32 --libdir lib32
+
+ arch-meson "$_pkgbase" build32 \
+ --libdir lib/mangohud/lib32 \
+ --prefix /usr \
+ -Dappend_libdir_mangohud=false \
+ -Dinclude_doc=false
+
ninja -C build32
}
package_mangohud-git() {
pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more'
- depends=('gcc-libs' 'libx11')
conflicts=('mangohud')
DESTDIR="$pkgdir" ninja -C build64 install
- sed -i -e 's|libMangoHud.so|/usr/lib/&|g' "$pkgdir/usr/share/vulkan/implicit_layer.d/mangohud.json"
- install -Dm644 "$_pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_lib32-mangohud-git() {
pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32-bit)'
- depends=('lib32-gcc-libs' 'lib32-libx11')
conflicts=('lib32-mangohud')
DESTDIR="$pkgdir" ninja -C build32 install
- mv "$pkgdir/usr/share/vulkan/implicit_layer.d/"mangohud{,32}.json
- sed -i -e 's|libMangoHud.so|/usr/lib32/&|g' -e 's|64bit|32bit|g' "$pkgdir/usr/share/vulkan/implicit_layer.d/mangohud32.json"
+}
+
+package_mangohud-common-git() {
+ pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more'
+ conflicts=('mangohud-common')
- install -Dm644 "$_pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm664 "$_pkgbase/bin/MangoHud.conf" "$pkgdir/usr/share/doc/mangohud/MangoHud.conf.example"
+ install -Dm664 "$_pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$_pkgbase/LICENSE"
}