summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGroctel2020-12-05 14:46:02 +0100
committerGroctel2020-12-05 14:46:02 +0100
commit36d03913d7e36a47a7a20b756eb82ad1446e0d0f (patch)
treec83f1f9ac3b3374f00ea8e810256d0d9ded94a02 /PKGBUILD
parentdcf4ff707dbc1cf0dd7af402221c194eda99d8e2 (diff)
downloadaur-36d03913d7e36a47a7a20b756eb82ad1446e0d0f.tar.gz
Updated to v0.1.1
Also fixed some installation errors and warnings
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69da8775c443..1d573fe9e6b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Groctel <aur@taxorubio.com>
pkgname=manimce
-pkgver=0.1.0
+pkgver=0.1.1
pkgrel=1
pkgdesc="Animation engine for explanatory math videos (community edition)."
arch=('any')
@@ -10,6 +10,7 @@ depends=(
'cairo'
'ffmpeg'
'python'
+ 'python-cairo'
'python-cairocffi'
'python-colour'
'python-numpy'
@@ -20,9 +21,6 @@ depends=(
'python-scipy'
'python-tqdm'
'python-watchdog'
-
- # AUR package
- 'python-pydub'
)
makedepends=(
'python-pip'
@@ -33,22 +31,19 @@ optdepends=(
)
provides=()
conflicts=('python-manimlib')
-source=("https://files.pythonhosted.org/packages/f9/17/5b538d8350983c9a3baaaaa0345a0def774be463c909f61d56798a275089/manimce-0.1.0.tar.gz")
-sha256sums=('402c0c91efe29375ba2a6306d48147b827922f34a3f5e3bef792829751dce550')
+source=("https://github.com/ManimCommunity/manim/releases/download/v$pkgver/manimce-$pkgver.tar.gz")
+sha256sums=('9660f1bf2a9696e6b4c5313ffb4b223f66468df5ab554bc605ff42ce1076b9b2')
prepare() {
pip install pip --upgrade
- # This line may seem redundant but pangocairocffi refuses to install if
- # pangocffi isn't already installed (and then must be installed again because
- # the upgrading strategies always upgrade pangocffi). I'm keeping and eye on
- # this step to make it more polite or replace it with actual arch packages
- pip install --no-cache --force --use-feature=2020-resolver pangocffi==0.6.0
- pip install --no-cache --force --use-feature=2020-resolver \
+ pip install --no-cache --force \
grpcio \
grpcio-tools \
- pangocffi==0.6.0 \
+ pangocffi==0.8.0 \
pangocairocffi \
- progressbar
+ progressbar \
+ pydub \
+ rich==6.0
}
build() {