summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGroctel2021-04-04 23:13:50 +0200
committerGroctel2021-04-04 23:13:50 +0200
commit7e9340ea2f35043f2c1829493f364afa4fc6cee6 (patch)
treee7da04e6b6ff33fce28dbe51158293c996854f72 /PKGBUILD
parent7570f12143c9f09dc78e7ec098f24c640a9a2125 (diff)
downloadaur-7e9340ea2f35043f2c1829493f364afa4fc6cee6.tar.gz
Updated to 0.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a36196632b56..c00aef8e3588 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,34 @@
pkgbase=manimce
pkgname=manim-community
_name=manim
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="Animation engine for explanatory math videos (community edition)."
arch=('any')
url="https://www.manim.community/"
license=('MIT' 'custom')
depends=(
- 'python'
'ffmpeg'
+ 'python'
'python-cairo'
+ 'python-click'
+ 'python-click-default-group'
'python-colour'
+ 'python-decorator'
'python-networkx'
'python-numpy'
'python-pillow'
'python-pygments'
'python-rich'
'python-scipy'
+ 'python-setuptools'
'python-tqdm'
# Aur dependencies
+ 'python-cloup'
'python-manimpango'
+ 'python-mapbox-earcut'
+ 'python-moderngl-git'
+ 'python-glcontext'
'python-pydub'
)
makedepends=(
@@ -33,7 +41,7 @@ optdepends=(
conflicts=('python-manimlib')
provides=()
source=("https://github.com/ManimCommunity/$_name/releases/download/v$pkgver/$_name-$pkgver.tar.gz")
-sha512sums=('302ca49b71e7e432fcdb97ba94de3ff59dd39f60a8fe0b883f45e54e674ebbcf6d10ef025ca7aebedfe5fa2d793ef6966e9d2bd9ea56c0bb226171a485a5e263')
+sha512sums=('d736156a7e359f65575d96ab389fda7d4a65ba19d9a28ddf827a9b2f2566e67fd52053de70f41357120b71225a266ef1352a39876b60fd897e10a155c0110469')
prepare() {
cd "$srcdir/$_name-$pkgver"