summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgroctel2023-11-26 11:59:07 +0100
committergroctel2023-11-26 11:59:07 +0100
commit9db0b1c71f90acb2070844e4a3142b3183be4a78 (patch)
tree45ed2411c9002a4fdd3f5373d25c1f47af8f194f /PKGBUILD
parent2c5b7bf7c55046747113e5a4f024fb920c1220af (diff)
downloadaur-9db0b1c71f90acb2070844e4a3142b3183be4a78.tar.gz
Updated to 0.18.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD118
1 files changed, 54 insertions, 64 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8eedc10362a4..efa46611ed6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,86 +1,76 @@
# Maintainer: Groctel <aur@taxorubio.com>
# Maintainer: Naveen M K <naveen521kk@gmail.com>
-_name=manim
pkgbase=manimce
pkgname=manim
-pkgver=0.17.3
+pkgver=0.18.0
pkgrel=1
pkgdesc="Animation engine for explanatory math videos (community edition)."
-arch=('any')
-license=('MIT' 'custom')
+arch=("any")
+license=("MIT" "custom")
url="https://github.com/ManimCommunity/manim"
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha512sums=('188fa537a2ee49b6d576ae191e0931dc71002a9ae1cfc8380ca51c03192ebc00e2c529dce1a2d210aa68d776274bace8aaa8691acfae78466970e553848e7f30')
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('d52a3c3f5780c41fe7164a5ae164d46e7b372c2616f72e04fdf0c79f66ccc791c9d82db79c8d8258159cdf8a6f701d9a61bf1c43f547fdbb8641e63235b36a78')
-conflicts=('python-manimlib')
+conflicts=("python-manimlib")
depends=(
- 'ffmpeg'
- 'python'
- 'python-cairo'
- 'python-click'
- 'python-click-default-group'
- 'python-colour'
- 'python-decorator'
- 'python-google-api-core'
- 'python-importlib-metadata'
- 'python-numpy'
- 'python-pillow'
- 'python-pygments'
- 'python-requests'
- 'python-rich'
- 'python-scipy'
- 'python-setuptools'
- 'python-tqdm'
- # 'python-watchdog' uses AUR git version while community is OOD
- 'python-networkx'
- # Aur dependencies
- 'python-cloup'
- 'python-backports.cached_property'
- 'python-glcontext'
- 'python-isosurfaces'
- 'python-manimpango'
- 'python-mapbox-earcut'
- 'python-moderngl'
- 'python-moderngl-window'
- 'python-pydub'
- 'python-screeninfo'
- 'python-skia-pathops'
- 'python-srt'
- 'python-svgelements'
- 'python-watchdog-git'
+ "ffmpeg"
+ "python"
+ "python-cairo"
+ "python-click"
+ "python-click-default-group"
+ "python-colour"
+ "python-decorator"
+ "python-google-api-core"
+ "python-importlib-metadata"
+ "python-numpy"
+ "python-pillow"
+ "python-pygments"
+ "python-requests"
+ "python-rich"
+ "python-scipy"
+ "python-setuptools"
+ "python-tqdm"
+ "python-watchdog"
+ "python-networkx"
+ # Aur dependencies
+ "python-cloup"
+ "python-backports.cached_property"
+ "python-glcontext"
+ "python-isosurfaces"
+ "python-manimpango"
+ "python-mapbox-earcut"
+ "python-moderngl"
+ "python-moderngl-window"
+ "python-pydub"
+ "python-screeninfo"
+ "python-skia-pathops"
+ "python-srt"
+ "python-svgelements"
)
makedepends=(
- 'python-build'
- 'python-installer'
- 'python-wheel'
- 'python-poetry-core'
+ "python-build"
+ "python-installer"
+ "python-setuptools"
+ "python-wheel"
)
optdepends=(
- 'jupyterlab: Jupyter something'
- 'python-grpcio-tools: WebGL renderer'
- 'texlive-core: LaTeX support'
+ "jupyterlab: Jupyter something"
+ "python-grpcio-tools: WebGL renderer"
+ "texlive-core: LaTeX support"
)
-prepare ()
-{
- cd "$srcdir/$pkgname-$pkgver"
- sed -i 's/cloup = "^0.13.0"/cloup = "*"/g' pyproject.toml
+build () {
+ cd "$srcdir/$pkgname-$pkgver" || exit
+ python -m build --wheel --no-isolation
}
-build ()
-{
- cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
-}
-
-package ()
-{
- cd "$srcdir/$pkgname-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 LICENSE.community "$pkgdir/usr/share/licenses/$pkgname/LICENSE.community"
+package () {
+ cd "$srcdir/$pkgname-$pkgver" || exit
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 LICENSE.community "$pkgdir/usr/share/licenses/$pkgname/LICENSE.community"
}