summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorstar20002020-07-04 18:13:55 +0800
committerstar20002020-07-04 18:13:55 +0800
commit60e2b2c1f22008436288462aa9ba35f99c9016ca (patch)
tree25646be6d25a574475d88335f05334a66ad1c2ae /PKGBUILD
parent271ff3e47a968b3c12f6efc13809ed40e780c86d (diff)
downloadaur-60e2b2c1f22008436288462aa9ba35f99c9016ca.tar.gz
move fcitx5 profile location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 16 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7918b66427b6..bcd65502942a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,33 @@
# Maintainer: Sam L. Yes <manjaroyes123@outlook.com>
-# Contributor: Stefano Capitani <stefanoatmanjarodororg>
+# Upstream Maintainer: Stefano Capitani <stefanoatmanjarodororg>
# Contributor: star2000 <i@star2000.work>
pkgbase=manjaro-asian-input-support
pkgname=('ibus-input-support' 'fcitx-input-support' 'fcitx5-input-support')
pkgver=2020.07
-pkgrel=1
+pkgrel=2
arch=('any')
url="https://gitlab.manjaro.org/packages/community/manjaro-asian-input-support"
license=('GPL')
pkgdesc='Asian input support from Manjaro'
source=(
'enable-fcitx.sh'
- 'enable-fcitx5.sh'
'enable-ibus.sh'
'fcitx5.desktop'
'fcitx5.profile'
'ibus.desktop'
)
md5sums=('fdbfae1bba8012daf984a76d7004ae3e'
- '8bc36e42f521ddf2c1ac0b98ff7ee394'
- 'b974be25b7f91c392009cb8d9f1bd5b4'
- '97a5be2b8ff8c0fc895d9ef21531e698'
- '3578677a7102c9f8be3b9f7ea7d3d06f'
- 'f1a9f3406f8268383149889f4816cd52')
+ 'b974be25b7f91c392009cb8d9f1bd5b4'
+ '97a5be2b8ff8c0fc895d9ef21531e698'
+ '3578677a7102c9f8be3b9f7ea7d3d06f'
+ 'f1a9f3406f8268383149889f4816cd52')
install=input-support.install
conflicts=(
- "${pkgbase}-ibus"
- "${pkgbase}-fcitx"
- "${pkgbase}-fcitx5"
- )
+ "${pkgbase}-ibus"
+ "${pkgbase}-fcitx"
+ "${pkgbase}-fcitx5"
+)
package_ibus-input-support() {
pkgdesc='Asian input support for ibus'
@@ -48,8 +46,8 @@ package_ibus-input-support() {
package_fcitx-input-support() {
pkgdesc='Asian input support for fcitx'
depends=(
- 'fcitx-qt5' # QT input module
- 'fcitx-configtool' # gui configuration tool
+ 'fcitx-qt5' # QT input module
+ 'fcitx-configtool' # gui configuration tool
)
optdepends=(
'fcitx-qt4: required by some closed source Chinese IMEs'
@@ -69,8 +67,8 @@ package_fcitx-input-support() {
package_fcitx5-input-support() {
pkgdesc='Asian input support for fcitx5'
depends=(
- 'fcitx5-qt' # QT input module
- 'fcitx5-gtk' # GTK input module
+ 'fcitx5-qt' # QT input module
+ 'fcitx5-gtk' # GTK input module
)
optdepends=(
'kcm-fcitx5: KDE configuration module'
@@ -81,7 +79,7 @@ package_fcitx5-input-support() {
'fcitx5-unikey: Tiếng Việt | Vietnamese'
)
provides=("${pkgbase}-fcitx5")
- install -Dm644 "$srcdir/enable-fcitx5.sh" "$pkgdir/etc/profile.d/input-support.sh"
+ install -Dm644 "$srcdir/enable-fcitx.sh" "$pkgdir/etc/profile.d/input-support.sh"
install -Dm644 "$srcdir/fcitx5.desktop" "$pkgdir/etc/xdg/autostart/fcitx5.desktop"
- install -Dm644 "$srcdir/fcitx5.profile" "$pkgdir/usr/share/$pkgname/profile"
+ install -Dm644 "$srcdir/fcitx5.profile" "$pkgdir/etc/xdg/fcitx5/profile"
}